12

Report network latency issue

If you are experiencing some latency issue or non-ideal routing, please use our diagnostic tool to report it. The tool can run on your computer or router. It gathers and submit network measurements that will help us improve our network. You can then use the generated diagnostic link to report your issue on the Help Forum.

Please follow the instruction for your platform below:

MacOS, Linux, *BSD, Linux based routers

Open a terminal, run the following command and follow the instructions:

sh -c 'sh -c "$(curl -s https://nextdns.io/diag)"'

Windows

  1. Download and run this program.
  2. If you get a virus alert, you can disregard it, see note below.
  3. Follow the instructions

If you find bugs in the tool itself, please log an issues on the Github repository.

125 replies

    • ray_toth
    • 2 yrs ago
    • Reported - view

    Usene tons on Android cell phone with Android private dns turned like dite tells how love nextdns but here my ping  

    heficed-chi (IPv6)      32 ms  (ultralow1)

      heficed-chi             33 ms  (ultralow1)

      vultr-chi               39 ms  (anycast1, ultralow2)

      vultr-chi (IPv6)        39 ms  (anycast1, ultralow2)

      teraswitch-pit          50 ms

      zepto-iad               52 ms

      zepto-mci (IPv6)        54 ms

      teraswitch-pit (IPv6)   57 ms

      zepto-iad (IPv6)        68 ms

      zepto-xrs (IPv6)        73 ms

      router-pit              74 ms

      anexia-mnz              77 ms

      zepto-xrs               78 ms

      hydron-clt              78 ms

      hydron-clt (IPv6)       79 ms

      anexia-mnz (IPv6)       80 ms

      smarthost-mci (IPv6)    81 ms

      smarthost-mci           97 ms

      zepto-mci               98 ms

      anexia-ams (IPv6)      114 ms  (anycast2)

      anexia-ams             132 ms  

    I'm in desplaines il USA use on my home router also but ping on android cell phone for now showing here

    • Live and Let Die
    • Cylac
    • 2 yrs ago
    • Reported - view

    figured I'd share my results too! I'm "guessing" it looks good? ;)

    https://nextdns.io/diag/742bc560-82b1-11eb-abe8-11b40072f372

    • 馃
    • MarkToon
    • 2 yrs ago
    • Reported - view

    Waste of time reporting your statistics if they don't bother to reply. 

    Wasted money subscribing to NextDNS due to repeated instances of high latency or no connection (in between it been very good)

     

    There's a reason NextDNS don't have a "Service status" page.

    • mihai
    • 2 yrs ago
    • Reported - view

    Absolutely agree....

    • Stanislas
    • 2 yrs ago
    • Reported - view

    Having issues from Orange France FTTH to netbarista-par-1.

      • olivier
      • 2 yrs ago
      • Reported - view

      Stanislas please send a diag

      • Stanislas
      • 2 yrs ago
      • Reported - view

      Olivier Poitrey I would like to, but it's stuck on a traceroute 馃槦 (like https://github.com/nextdns/diag/issues/3)

      • Stanislas
      • 2 yrs ago
      • Reported - view

      Olivier Poitrey Okay, it worked from another device: https://nextdns.io/diag/73ccd2c0-89d3-11eb-9842-b351f7e87eda

      However I have been getting less packet loss for half an hour. I should try a diag again when it's back.

      • olivier
      • 2 yrs ago
      • Reported - view

      Stanislas are you also monitoring some other providers to rule out an issue with your own connection?

      • Stanislas
      • 2 yrs ago
      • Reported - view

      Olivier Poitrey I do have other smokeping probes that do not display any loss: https://imgur.com/a/Tv1S8yZ

      • olivier
      • 2 yrs ago
      • Reported - view

      Stanislas is it better now?

      • Stanislas
      • 2 yrs ago
      • Reported - view

      Olivier Poitrey It seems to be better (so far)

      I had some latency spikes last night without loss, during which I run a mtr (ipv6):
       

       Host                                                          Loss%   Snt   Last   Avg  Best  Wrst StDev
       1. livebox.home                                                0.0%   156    1.0   1.2   0.9   5.9   0.6
       2. xxx.ipv6.abo.wanadoo.fr                                     0.0%   155    2.6   2.6   1.5  11.4   1.2
       3. 2a01:cfc4::b                                                0.0%   155    3.7   4.2   2.4  67.0   6.1
       4. bundle-ether104.pastr4.paris.opentransit.net               98.7%   155    3.4   3.0   2.6   3.4   0.6
       5. ae-26.r04.parsfr01.fr.bb.gin.ntt.net                        0.0%   155   26.8  29.3  24.0  53.1   3.2
       6. xe-0-6-0-2-1.r04.parsfr01.fr.ce.gin.ntt.net                 0.0%   155   28.1  31.0  23.2  88.6  10.1
       7. dns.nextdns.io                                              0.0%   155   29.0  28.3  22.7  38.2   2.1
      

      We'll see how it will evolve in the next few days 馃檪

      • Stanislas
      • 2 yrs ago
      • Reported - view

      It's not better.

      • Stanislas
      • 2 yrs ago
      • Reported - view
    • BigDargon
    • 2 yrs ago
    • Reported - view

    Ultra low for IPv6 is not working. And routing anycast 1 was too slow. Please check it! Thank you!

    Anycast 1 connet to zepto-mad https://nextdns.io/diag/25f81500-8de3-11eb-8a6e-3fd26ddfe68f

    Anycast 1 connect to zepto-hkg https://nextdns.io/diag/fde2bd80-8de3-11eb-8a6e-3fd26ddfe68f

      • BigDargon
      • 2 yrs ago
      • Reported - view

      Olivier Poitrey please check this issues, IPv6 cannot work!

        greencloud-han (IPv6)    28 ms
      鈻 greencloud-han           31 ms  (ultralow2)
        anexia-han               35 ms  (ultralow1)
        vultr-sin                50 ms
        premiumrdp-bkk           58 ms
        zepto-hkg (IPv6)         61 ms  (anycast1)
        anexia-sin (IPv6)        62 ms
        serverwala-kul           62 ms
        premiumrdp-kul           64 ms
        bangmod-bkk              67 ms
        vultr-sin (IPv6)         73 ms
        zepto-sin                76 ms
        zepto-sin (IPv6)         90 ms
        gsl-sin                 102 ms
        vultr-tyo (IPv6)        102 ms  (anycast2)
        anexia-sin              111 ms
        anexia-hkg              187 ms  (anycast2)
        zepto-mad               192 ms  (anycast1)
        gsl-sin (IPv6)           error
        dns1.nextdns.io (IPv6) error (ultralow1)
        dns2.nextdns.io (IPv6) error (ultralow2)
      
    • Remi
    • 2 yrs ago
    • Reported - view
    • ChrisK
    • 2 yrs ago
    • Reported - view

    Hello support team,

    I am facing network performance issues (especially in Multiplayer Online Games and with Audio / Video Streaming (e.g. Amazon Prime / Apple Music or Video). I am using a Peplink Balance Router with 2 WAN internet providers (Telekom DSL and Vodafone LTE) to gain enough speed at our countryside region in south-west of Germany close to the French border (slow bandwith region far away from bigger cities).  I am unsing 2 different nextdns-Profiles for every of the lines (having a separate dyndns address each).

    Can the problem maybe have todo with my location, as Nextdns seems to connect to DNS Servers at France insteand of German servers?

    I would appreciate, if you could please review the following logs.

    Diagnose results using Telekom: https://nextdns.io/diag/ba295220-93a1-11eb-ac31-f10bbd007106

    Diagnose results using Vodafone: https://nextdns.io/diag/ea674920-93a0-11eb-ac31-f10bbd007106

    Something I can do?

    Kind regards,

    ChrisK

      • olivier
      • 2 yrs ago
      • Reported - view

      ChrisK fra is Frankfurt, not France.

      • olivier
      • 2 yrs ago
      • Reported - view

      ChrisK is it different if you are using your ISP resolver?

      • ChrisK
      • 2 yrs ago
      • Reported - view

      Olivier Poitrey : Thanks for explanation.

      Yes, when I activate my 2 provider鈥榮 DNS servers (DHCP Auto Assign by providers router) or manually assign CloudFlare DNs Servers, I am not facing any issues.

      • olivier
      • 2 yrs ago
      • Reported - view

      ChrisK do you have ECS enabled in the settings?

      • ChrisK
      • 2 yrs ago
      • Reported - view

      Olivier Poitrey : Salut Olivier, yes, EDNS-Client Subnet is active.

      • olivier
      • 2 yrs ago
      • Reported - view

      ChrisK please try without it. Also, if you are able to identify the hostname that is getting slower, it would be helpful. You can check the logs when you use the game and try pinging them with and without nextdns to see if there is a latency difference.

      • ChrisK
      • 2 yrs ago
      • Reported - view

      Olivier Poitrey : Ok, to disable anonymous content provider network  (ECS) setting helped a lot with Multiplayer Game performance. Thank you.