12

Report network latency issue

If you are experiencing some latency issue or non-ideal routing, please use our diagnostic tool to report it. The tool can run on your computer or router. It gathers and submit network measurements that will help us improve our network. You can then use the generated diagnostic link to report your issue on the Help Forum.

Please follow the instruction for your platform below:

MacOS, Linux, *BSD, Linux based routers

Open a terminal, run the following command and follow the instructions:

sh -c 'sh -c "$(curl -s https://nextdns.io/diag)"'

Windows

  1. Download and run this program.
  2. If you get a virus alert, you can disregard it, see note below.
  3. Follow the instructions

If you find bugs in the tool itself, please log an issues on the Github repository.

124 replies

    • ChrisK
    • 3 yrs ago
    • Reported - view

    Hello support team,

    I am facing network performance issues (especially in Multiplayer Online Games and with Audio / Video Streaming (e.g. Amazon Prime / Apple Music or Video). I am using a Peplink Balance Router with 2 WAN internet providers (Telekom DSL and Vodafone LTE) to gain enough speed at our countryside region in south-west of Germany close to the French border (slow bandwith region far away from bigger cities).  I am unsing 2 different nextdns-Profiles for every of the lines (having a separate dyndns address each).

    Can the problem maybe have todo with my location, as Nextdns seems to connect to DNS Servers at France insteand of German servers?

    I would appreciate, if you could please review the following logs.

    Diagnose results using Telekom: https://nextdns.io/diag/ba295220-93a1-11eb-ac31-f10bbd007106

    Diagnose results using Vodafone: https://nextdns.io/diag/ea674920-93a0-11eb-ac31-f10bbd007106

    Something I can do?

    Kind regards,

    ChrisK

      • ChrisK
      • 3 yrs ago
      • Reported - view

      Olivier Poitrey : removed cache boosting and cname flattening. Seems to have increased speed further. Will upload new diags later. Hapyy Easter!

      • ChrisK
      • 3 yrs ago
      • Reported - view

       After the config change as described above, I receive this diagnose results (seems to be faster :-)):

      1) using Telekom DSL: https://nextdns.io/diag/120d10a0-953a-11eb-bc22-135c805ca4b6

      2) using Vodafone LTE: https://nextdns.io/diag/31a6b4b0-953b-11eb-bc22-135c805ca4b6

      Thanks for your kind help!

      • ChrisK
      • 3 yrs ago
      • Reported - view

      What is the technical reason that disabling ECS, cacheboosting and cname flattening boosts the speed? 

      • ChrisK
      • 3 yrs ago
      • Reported - view

      Olivier Poitrey : Do you maybe have any explanation for that?

    • Khairul
    • 3 yrs ago
    • Reported - view

    My IPv6 messed up, route to edgeuno-sao (332 ms). Please help!!!

    NextDNS Network Diagnostic

    • Paul.1
    • 3 yrs ago
    • Reported - view
    • Gaurish_Prabhudesai
    • 3 yrs ago
    • Reported - view

    Hello!

    I’m having issues getting the closest server. Keeps on going to zepto-sin and is fixed if I restart the service or router (CLI on ASUS router). 
     

    Diag: https://nextdns.io/diag/ab11bbe0-9b05-11eb-a929-d7a42f8e7e37

    • takezo
    • 3 yrs ago
    • Reported - view
    • Phil_S
    • 3 yrs ago
    • Reported - view
    • tushar_sharma
    • 3 yrs ago
    • Reported - view

    connecting far away servers high ping by around 50 to 60 ms on average.  My nearest one serverwala-del 4ms and microhost-del 4 ms connecting to ■ do-blr 52 ms (ultralow1) any good reason.

     

    Diagnostic Tool Report 21- April-2021 https://nextdns.io/diag/75355ba0-a2ba-11eb-ba97-31f721ac5087

    • ray_toth
    • 3 yrs ago
    • Reported - view
    • owine
    • 3 yrs ago
    • Reported - view

    CLI client keeps being routed to `anexia-lis` POP despite being US based. I am on a UDM Pro. The diag script on the router itself is stalling because one of the traceroutes does not complete. The linked output here is from my laptop and I've pasted some of the output from diag on the UDMP below as well.

    Laptop output: https://nextdns.io/diag/f580fc00-a9c3-11eb-85e8-a1be87597512

    Router partial output:

    Testing IPv6 connectivity
      available: false
    Fetching https://test.nextdns.io
      status: unconfigured
      client: redacted (same as linked output above)
      resolver: 108.162.217.49
    Fetching PoP name for ultra low latency primary IPv4 (ipv4.dns1.nextdns.io)
      anexia-lis: 110.803ms
    Fetching PoP name for ultra low latency secondary IPv4 (ipv4.dns2.nextdns.io)
      vultr-chi: 2.386ms
    Fetching PoP name for anycast primary IPv4 (45.90.28.0)
      anexia-lis: 111.535ms
    Fetching PoP name for anycast secondary IPv4 (45.90.30.0)
      virtua-par: 93.43ms
    Pinging PoPs
      vultr-chi: 2.4ms
      heficed-chi: 3ms
      teraswitch-pit: 13.059ms
      zepto-mci: 13.366ms
      router-pit: 13.333ms
      smarthost-mci: 18.493ms
      zepto-iad: 18.838ms
      zepto-xrs: 19.316ms
      anexia-mnz: 22.031ms
      hydron-clt: 23.359ms
    Traceroute for ultra low latency primary IPv4 (45.90.28.0)
        1    10.16.160.1    0ms   0ms   0ms
        2   204.14.39.94    0ms   0ms   0ms
        3 142.147.56.170    0ms   0ms   0ms
        4  142.147.56.32    0ms   0ms   0ms
        5 142.147.56.144    0ms   0ms   0ms
        6   38.142.126.1    2ms   1ms   1ms
        7   154.24.45.85    1ms   1ms   1ms
        8  154.54.81.109    1ms   1ms   1ms
        9   154.54.7.130    8ms   8ms   9ms
       10  154.54.82.254   20ms  20ms  20ms
       11  154.54.85.246   92ms  92ms  93ms
       12  154.54.61.106  105ms 105ms 105ms
       13  154.54.61.213  111ms 112ms 113ms
       14   149.6.145.58  109ms 109ms 109ms
       15   5.206.230.36  110ms 110ms 110ms
       16     45.90.28.0  110ms 109ms 110ms
    Traceroute for ultra low latency secondary IPv4 (45.76.16.236)
        1    10.16.160.1    0ms   0ms   0ms
        2   204.14.39.94    0ms   0ms   0ms
        3 142.147.56.170    0ms   0ms   0ms
        4  142.147.56.32    0ms   0ms   0ms
        5 142.147.56.144    0ms   0ms   0ms
        6   38.142.126.1    5ms   1ms   1ms
        7   154.24.45.85    1ms   1ms   1ms
        8  154.54.81.109    1ms   1ms   1ms
        9  154.54.46.178    1ms   5ms   1ms
       10   154.54.12.38    1ms   1ms   1ms
       11 62.115.122.195    1ms   6ms   1ms
       12 62.115.148.197    2ms   4ms   3ms
    
    • Carrot_eggs
    • 3 yrs ago
    • Reported - view

    I think my network can be saved, please help adjust the network to China. The link seems to be reset.发😢

    https://nextdns.io/diag/f40bccb0-ac2a-11eb-a162-0da303692285

    https://nextdns.io/diag/c54e17a0-ac2c-11eb-a162-0da303692285

    • Suedroc
    • 3 yrs ago
    • Reported - view

    Using nextdns-cli 1.32.1-2 on openwrt.

    https://nextdns.io/diag/d2c56790-ac6c-11eb-a162-0da303692285

    • Suedroc
    • 3 yrs ago
    • Reported - view

    Need help on this one.

    https://nextdns.io/diag/baa05100-afa7-11eb-90c4-c358a688f39d

    Is it possible to lock in on a specific region?

    • ray_toth
    • 3 yrs ago
    • Reported - view

    Some people tell me my iPhone look like I'm in USA needs fixing

    • Anthony
    • 3 yrs ago
    • Reported - view

    Hey guys, would appreciate it if you could give me some feedback on this. 

    https://nextdns.io/diag/93656d40-b214-11eb-ad4d-7bf757c73c07

    I don't think I am connecting to the ultra low latency servers at all, my average response time is in the region of 200-300ms. So I suspect that I am connecting to edgeuno-sao or anexia-lon

    Please advise on how I can optimally connect to the closest server.

    Thanks.

      • Anthony
      • 3 yrs ago
      • Reported - view

      Anthony 

      Just following up on this. Any update at all about this guys?

      Since there does not seem to be any response....

    • it_doesnt_matter
    • 3 yrs ago
    • Reported - view

    My connection is since yesterday and today very slow. 

    • Umur_Soydan
    • 3 yrs ago
    • Reported - view

    there is generally best one  premiumrdp-ist but when checing ping its going to server edgeuno-ist 

    here is the diag : https://nextdns.io/diag/a311a6e0-b30a-11eb-b651-bd1b4832df5d

    pls can you fix it to premiumrdp-ist

    • T_f
    • 3 yrs ago
    • Reported - view

    Since as a private user I do not have the possibility to send an email, I leave my good-bye comment here: I tried the service and even signed up for a paid yearly plan but after some weeks of usage I repeatedly got outages where I could not open a legit website. Happened both on mobile and desktop devices across the family. It seems the DNS server was down. After a couple of minutes it worked again but this was not acceptable. Switched back to Cloudflare for families again. Would have loved to use the service because I think the idea is great.

    https://nextdns.io/diag/26e54060-b3d0-11eb-b104-fb4765e971c6 in case anyone wants to investigate further. Diagnostics was created after I switched back to Cloudflare.

    • Serious_Hoax
    • 3 yrs ago
    • Reported - view

    Here's mine. Can anything be improved? I'm using it in YogaDNS. Set it to 45.90.30.*** because this one seems to have lower a ping than 45.90.28.*** and ultra latency option in YogaDNS.

    https://nextdns.io/diag/36294160-b67e-11eb-81b0-57e31c7e4595

    • Adam_Roberts
    • 3 yrs ago
    • Reported - view

    Hi!

    I am using NextDNS CLI on a UDM Pro.  Everything on my LAN is using the UDM Pro for DNS and works great except for POP selection.

    I ran the diag, which shows the usual experience - there are IPv6 POPs with much lower latency not being used via my network:

    https://nextdns.io/diag/05950970-b742-11eb-a7c6-9191009ccac3

    Geographically speaking certainly not far off - I don't know if my ISP has their subnet spanning multiple sites.  Any tweaking NextDNS could do would be great!

     

    Cheers!

      • Adam_Roberts
      • 2 yrs ago
      • Reported - view

      Adam Roberts Turns out, if I disable CNAME flattening I consistently hit the closest ultralow POP.

    • Panos_Boulougouras
    • 2 yrs ago
    • Reported - view

    https://nextdns.io/diag/3176a8e0-bd9c-11eb-a028-7d3a947c337e

    why i am always connecting  to slower servers (45ms+) and never to fast ones (22ms)?

    Thank you.