1

Logs not recording queries on my computer / Settings change not applying

Queries from my computer do not appear anymore in logs, but queries from my android phone still appear 

setup : 

windows 11 desktop 

DNS settings are still applied (as p*rn is blocked) but they are frozen (eg. if I allow p*rn in the settings it is still blocked). 

Since 15/12/23 ~9:00PM (EUW)

24 replies

null
    • revue_2_presse
    • 5 mths ago
    • Reported - view

    Hello !

    I'd like to report some similar behavior.
    Quite confusing at first since the logs do not reflect - entirely - what is going
    (some domains are blocked according to DNS-over-TLS responses even though they do not show up in logs as blocked).

    Please find enclosed a domain example (which is not blocked by some setting, or i would not know which one since it doesn't show up in the logs at all unless i query the local resolver proxy with nslookup) - similar response with DNS-over-TLS for type AAAA.

    Thank you for your support,

      • revue_2_presse
      • 5 mths ago
      • Reported - view

      DNS-over-HTTPS not DNS-over-TLS 

      • REVOL7
      • 5 mths ago
      • Reported - view

      seems related to https://help.nextdns.io/t/h7y3mmh/synchro-issue-between-nextdns-server

       

       , @Christophe Yayon and myself are all living in France it seems, might be a coincidence tho.

      • NextDNs
      • 5 mths ago
      • Reported - view

      could be related. Do you still have the issue?

      • REVOL7
      • 5 mths ago
      • Reported - view

       thank you for your answer, I still have the issue, I might reinstall windows but I don't know if the cause of the issue is on my side.

      To remind you of my situation and clarify : 

      1) my device is connected to NextDNS 

      2) Logs are broken, no queries appears except when I'm using qBitorrent or other very rare cases like when I execute the diag it displays "ipv6.test-ipv6.is"

      3) filtering (parental control at least) is working but changes in the filtering do not apply to my device.

      • REVOL7
      • 4 mths ago
      • Reported - view

       it looks like the issue got fixed for me 10 mn ago, I don't know how

      • revue_2_presse
      • 4 mths ago
      • Reported - view

       Same here for me.
      I can see the logs previously missing in some cases,
      and toggling some domain filters now has the expected effects 🙂

      • NextDNs
      • 4 mths ago
      • Reported - view

       we identified the issue and rolled out a fix

      • REVOL7
      • 4 mths ago
      • Reported - view

       thank you guys!

      • REVOL7
      • 2 mths ago
      • Reported - view

       this issue is back it seems

      • revue_2_presse
      • 2 mths ago
      • Reported - view

       @NextDNS

      Unfortunately, I have to concur with this observation!

      Here is a diag file.

      • NextDNs
      • 2 mths ago
      • Reported - view

      does it still happen today? What do you get for https://test.nextdns.io

      • revue_2_presse
      • 2 mths ago
      • Reported - view

       Tests conducted on my site provides with satisfying results now! ✅🙆🙂 
      (based on trying to resolve internalfb.com before blocking it successfully for instance)
      Thanks! 🙇🏻

      • REVOL7
      • 2 mths ago
      • Reported - view

      Fixed for me !

    • NextDNs
    • 5 mths ago
    • Reported - view

    Please provide a https://nextdns.io/diag

      • revue_2_presse
      • 5 mths ago
      • Reported - view
      • revue_2_presse
      • 5 mths ago
      • Reported - view

      Being puzzled by the `unconfigured ` status provided when running the diag command,
      and in spite of having some `ok` status when accessing test.nextdns.io from a configured browser tab, i replaced the DNS addresses declared at the router level before running the diag command again: https://nextdns.io/diag/291c6710-9cf2-11ee-a051-edbacc10344b

      # from test.nextdns.io
      "status": "ok"
      • NextDNs
      • 5 mths ago
      • Reported - view

      do you still have the issue?

      • revue_2_presse
      • 5 mths ago
      • Reported - view

       I still do have this issue.

      No logs matching the problematic domain queried from https://my.nextdns.io/****/logs when accessing some domains blocked from a browser tab with DNS-over-HTTPS configured with `Additional` field returned filled with 
      ```

      \n;; OPT PSEUDOSECTION:\n; EDNS: version 0; flags:; udp: 4096\n; EDE: 17 (Filtered): (Blocked by NextDNS)
      ```
      when executing curl against the dns.nextdns.io ... endpoint (similar response than before attached)
      even though the domain is clearly not blocked by some rules since i can access it via direct lookup.

      In a nutshell, by removing the browser configuration, it's ok and as soon as DNS-over-HTTPS is involved, i can't seem to trust the logs, nor the filtering rules.

      Also changing DoH in the browser allows me to access again the filtered domain immediately.
      I've reinstalled nextdns app from the App Store, CLI multiple times. Nothing changed so far unfortunately.

      Here is another diag if that may help:
      https://nextdns.io/diag/cef9d1d0-9d2a-11ee-b179-3decc7f48952

      Thank you for your support,

       

      • NextDNs
      • 5 mths ago
      • Reported - view

       please try these:

      curl 'https://dns.nextdns.io/<your profile id>?name=web.whatsapp.com&class=chaos'|jq
      
      dig chaos web.whatsapp.com @192.0.2.42
      
      • revue_2_presse
      • 5 mths ago
      • Reported - view

       
      `curl` command execution output:

      FYI, i had removed all lists https://my.nextdns.io/****/privacy at some point and it didn't bring the logs back....

      `dig` command execution output: 
      image

      • revue_2_presse
      • 5 mths ago
      • Reported - view

      Fyi, at the moment, the blocklist do not contain the incrimated list (no-facebook) per illustrated configuration.
       

      • revue_2_presse
      • 4 mths ago
      • Reported - view

      The encountered problem appears to be solved for me now

      Thank you!

      • revue_2_presse
      • 2 mths ago
      • Reported - view

      Running this command again with internalfb.com for instance outputs
       

      # curl 'https://dns.nextdns.io/***?name=internalfb.com&class=chaos
      
      {
        "Status": 0,
        "TC": false,
        "RD": true,
        "RA": true,
        "AD": false,
        "CD": false,
        "Question": [
          {
            "name": "internalfb.com.",
            "type": 1
          }
        ],
        "Answer": [
          {
            "name": "internalfb.com.",
            "type": 1,
            "TTL": 300,
            "data": "0.0.0.0"
          }
        ],
        "Additional": [
          {
            "name": ".",
            "type": 41,
            "TTL": 0,
            "data": "\n;; OPT PSEUDOSECTION:\n; EDNS: version 0; flags:; udp: 4096\n; EDE: 17 (Filtered): (Blocked by NextDNS)"
          },
          {
            "name": "proto.nextdns.io.",
            "type": 16,
            "TTL": 0,
            "data": "\"DOH\""
          },
          {
            "name": "server.nextdns.io.",
            "type": 16,
            "TTL": 0,
            "data": "\"virtua-par-1\""
          },
          {
            "name": "profile.nextdns.io.",
            "type": 16,
            "TTL": 0,
            "data": "\"****\""
          },
          {
            "name": "client.nextdns.io.",
            "type": 16,
            "TTL": 0,
            "data": "\"****\""
          },
          {
            "name": "client-name.nextdns.io.",
            "type": 16,
            "TTL": 0,
            "data": "\"unknown-doh\""
          },
          {
            "name": "lists.nextdns.io.",
            "type": 16,
            "TTL": 0,
            "data": "\"blocklist:hagezi-multi-ultimate\" \"blocklist:hagezi-multi-pro-plus\""
          },
          {
            "name": "smart-ecs.nextdns.io.",
            "type": 16,
            "TTL": 0,
            "data": "\"not sent\""
          }
        ]
      }

      Now trying to disable the blocking list (even though, i have manually whitelisted `*.internalfb.com` before without being able to access the domain from a browser configure resolving domains via DNS-over-HTTPS)

Content aside

  • 1 Likes
  • 2 mths agoLast active
  • 24Replies
  • 321Views
  • 6 Following