0

iOS app fails Excluded Wi-Fi Network

If I use the Excluded Wi-Fi Network:

1. When I’m on that network, nextdns app shows it is still connected when it should not be. Is it using bssid? 
2. when I’m not on that network, sometimes the app will simultaneously say that it is disabled because it is on a network that is miles away and not connected. 
 

this makes the iOS app d very unreliable. Any chance this can be fixed?

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Examples. Note the text says, “Didablrd on this Wi-Fi network “even when Wi-Fi is turned off. 

    Like
      • R P M
      • R_P_M
      • 2 wk ago
      • Reported - view

      Michael Bierman Try deleting all networks in the NextDNS settings under EXCLUDED WI-FI NETWORKS. Reboot phone. See how it behaves after that.

      Like
      • Taylor
      • Taylor_C
      • 2 wk ago
      • Reported - view

      Michael Bierman Is another device using Personal Hotspot?  Or is the blue indicator around the time for Maps?  You may have "turned off new connections" in Control Center but WiFi is still on in this picture.  "Not Connected" is not the same as "Off". You would have to tap "Wi-Fi" and toggle the slider there to actually turn off WiFi. I hate the way Apple does this now but that is another conversation.  LOL. 

      I suspect the app knows WiFi is enabled but it can't suss out that it's not actually being used for the phones data. This may be a limitation in the way iOS shares connection states though. 

      I found the app can be hit or miss and I ended up using the configuration profile. You're able to add a list of SSIDs there, but you would need to enter them all at time of creation. If you only have a network or two you need to exclude then that's probably the way to go. 

      Like
  • @taylor no hotspot. I'm not sure how that would be relevant, anyway. Best I can tell, nextdns does not use location. If they do, they have fooled Apple since it doesn't show up in Privacy permissions. 

    I think this came down to poor app refresh. If I

    1. Am on my home network.
    2. 2.  disable Wi-Fi.
    3. Kill the nextDNS app.
    4. Open nextDNS app.

    Then app is correct.  Same is true the other way. If I rejoin wifi the app shows incorrect status, but killing it and restarting it solves the problem. 

    Like
  • I was able to recreate  the problem you are seeing.    The clue is the switch being Yellow.      That means you have an entry in the Exclude Wifi list regarless of whether or not you are connected to the WiFi.

    Look in your Exclude WiFi list.    If you see an entry with a Red "minus" that means the Wifi has  been added to the exclude list.    Even if your Wifi is turned off, the switch will be yellow when NextDNS is disabled.   

    Click the red "minus" to remove the Wifi entry.    Your switch should be WHITE when NextDNS  off and BLUE when NextDNS is On.

    The interface is confusing when it comes to adding/removing Wifi Networks to the excusion list and it would be easy to get the setting backwards.

    If this doesn't make sense, please post a screenshot of your Exclude list.   Mine looks like this when "FastNet" is Excluded.   My switch is YELLOW when Wifi is turned off and I'm on Cellular

      

    Like
  • Thanks, @Calvin. 

    I"m not sure I follow. 

    That means you have an entry in the Exclude Wifi list regarless of whether or not you are connected to the WiFi.

    I only had one SSID listed in the app. 

    Look in your Exclude WiFi list.    If you see an entry with a Red "minus" that means the Wifi has  been added to the exclude list.  

    Yes. 

     Even if your Wifi is turned off, the switch will be yellow when NextDNS is disabled.   

    I don't think so. tapping the "-" removes the wifi SSID from the exclude list. If Wi-Fi is turned off then it should show that the connection is enabled. If you are on the excluded Wi-Fi then it should say excluded. 

    If you kill the nextDNS app after changing Wi-Fi state everything works correctly. This is a problem with the app updating the state. 

     

    Click the red "minus" to remove the Wifi entry.    Your switch should be WHITE when NextDNS  off and BLUE when NextDNS is On.

    Yes, and then it won't be excluded next time!

    Like
Like Follow
  • 2 wk agoLast active
  • 6Replies
  • 53Views
  • 4 Following