0

Can't access NextDNS — says 'set' on proxy: trap returned falsish for property 'isExodus'

I have my NextDNS servers setup under Custom DNS under Mullvad VPN and it has worked fine.

Then, I added a NextDNS Profile on my Mac Ventura 13.4.1 (c) because I noticed some DNS requests made by my computer was leaking.

 This seems to be working OK and I now see all the previously missed DNS requests made by my computer.

In addition, I also have the custom HTTPS DNS setup on my Brave Browser settings, like:

 The internet works fine, but I cannot go into my NextDNS or see my analytics or logs because I keep getting an error that says: 'set' on proxy: trap returned falsish for property 'isExodus' 

 I can still access my NextDNS analytics and logs from my mobile phone, which leads me to suspect that this error is a result of the NextDNS profile I added to my Mac. 

But, I'm not certain.

Any ideas on how to fix this?

Thanks!

P.S: I'm a paying customer of NextDNS, and I'm disappointed at their support. I understand they're trying to save money by creating a community forum instead of hiring support people, but not having dedicated support for paying early adopter customers isn't appreciated by me. 

8 replies

null
    • Blackstone230.1
    • 8 mths ago
    • Reported - view

    Hi Jay,

    Thanks for your report. 

     

     Can you confirm if you followed/tried this steps, please?

     

    Option A: Renew profile according with the following suggestions:

    Configuration Profile

    macOS Big Sur or higher

    Use our Apple Configuration Profile Generator available at apple.nextdns.io.

    Device Model --> Select your right device.

    * Trust NextDNS Root CA -->  should be disabled

     

    Option B:

    NextDNS for macOS

    1. Install our official app from the Mac App Store.

    2. Click on Preferences in the app status bar menu and go to the Configuration tab.

    3. Check "Use Custom Configuration" and enter "XXXXX" as Configuration ID.

    4. Enable NextDNS.

     

    Regards!

      • Jay.7
      • 8 mths ago
      • Reported - view

      Blackstone230 I already tried and have now re-tried Option A.

      Still no luck. 

      Also, I don't know if it's related, but my Mac drops the Wifi connection altogether on some WiFi networks to the point of being unable to work. 

      Any other ideas?

      • Blackstone230.1
      • 8 mths ago
      • Reported - view

       

      Thanks for your feedback.

      Test A: 

      1. Open Settings.
      2. Tap Wi-Fi.
      3. Tap the name of the Wi-Fi network you’re connected to.
      4. Scroll down and you’ll see the HTTP Proxy option at the bottom of the screen.
      5. By default, the HTTP Proxy option is set to Off. This means your iPhone won’t use a proxy at all when connected to the network.
      6. To enable automatic proxy detection, select Auto.  

      Test B:  Have you tested from more than one Internet Explorer? For example Chrome, Edge, Firefox?

      Test C:  Wifi connection can be rejected if a custom profile is trusted. Please try to locate and delete the firmed NextDNS connection (and others  not required)  from General Menu and Profile and Device Management and then setup again using Option A without certificate.

      Test D: You can also  try to delete the firmed NextDNS connection from General Menu and Profile and Device Management, delete de Wifi connection and setup using option B.

       

      Regards!

      • Jay.7
      • 7 mths ago
      • Reported - view

      Blackstone230 

      I tried using "auto proxy discovery" under my Mac's Wifi settings, no luck. 

      I also tried deleting the signed Profile, then using an unsigned Profile, and, no luck either.

      The same error displayed even without the profile, not sure if that's due to caching or not, but I hard refreshed the page too. 

      This is a very annoying problem.

      I couldn't even reset my password on Desktop because the password reset link would end up on the same error page. 

      It SEEMS to work on Safari, so perhaps it's a Brave Browser issue? 

      It also SEEMS to work on Incognito mode with Brave, so perhaps it's related to an extension?

      If so, I obviously cannot remove/disable ALL of my extension just to get @nextdns  working, so any ideas on which extension(s) might be causing the issue?

      These are the extensions I have:

      • Blackstone230.1
      • 7 mths ago
      • Reported - view

      Hi Jay 

       

      As you said, is not a general network issue. It's a Brave navigator issue.

      Some test to validate (one by one):

      1- Remember the format for Custom DNS in navigator is: https://dns.nextdns.io/"YourprofileID" (without " ")

      2 - Try Auto Proxy discover & Automatic Proxy configuration or only Automatic Proxy configuration

      3 - Disable one by one plugins starting with "i don't care about cookies" then " Remove Breadcrums"....

       

      Side Note: I always advice not to use Nextdns certificates because it's a factor that could add connection/compatibility issues and is not required for protection.

       

      Regards!

      • Jay.7
      • 7 mths ago
      • Reported - view

      Blackstone230 Okay, I don't know if NextDNS made a product update or not, but the problem seems to have been resolved altogether... at least for now!

      I also removed a bunch of plugins (like ProWritingAid, TagAssistant, JSON Viewer, Simple Scraper, Smile Always etc.) so it's also possible I fixed it myself 🙂

      One strange issue I'd like to solve is preventing the leaking of my actual IP address with DNS queries.

      For example, if I look at the IPs section under analytics, the vast majority of my queries show my VPN, which is good.

      (See the first two rows in the screenshot below, which shows my VPN IP)

      But, for some reason, the 3rd row shows my actual IP address and city.

      Granted, it's only a handful of queries (19 in this case) but I would like to plug that hole and prevent my IP from leaking.

      Any ideas on how I could prevent that?

      I've got NextDNS connected to virtually everything... Mullvad VPN, Brave Browser, and as a Profile on my Mac, so not sure where the leak is occurring as I cannot SEE which apps are responsible for those 19 queries.

      Thanks!

      • Joshua_Long
      • 6 mths ago
      • Reported - view

       those are likely queries made prior to a secure VPN connection at system boot, during a network change or some other similar leak during a connection/reconnect cycle.

      I believe the source of the query can be determined in the analytics or log page of your account, a long as the custom servers addresses as input on each device includes an identity tag the process which can be found on the account set up page i think.

    • NextDNs
    • 8 mths ago
    • Reported - view

    Please disabling all your browser extensions and try again.

Content aside

  • 6 mths agoLast active
  • 8Replies
  • 218Views
  • 4 Following