0

Profile Matching Not Working Correctly

Hello,

I recently installed the NextDNS CLI on my pfSense device. Below are my configuration details. I've attempted to set up conditional profiles for my VLANs, but it appears that regardless of the VLAN, the system consistently defaults to using the primary profile (ID: 12345). Any insights or suggestions would be greatly appreciated.

 

mdns all
bogus-priv true
use-hosts true
max-inflight-requests 256
debug false
cache-size 0
report-client-info true
detect-captive-portals true
hardened-privacy false
log-queries true
discovery-dns
auto-activate true
listen localhost:53
listen 10.1.1.1:53
listen 10.1.2.1:53
listen 10.1.3.1:53
listen 10.1.4.1:53
control /var/run/nextdns.sock
profile 10.1.1.1/24=12345
profile 10.1.2.1/24=45678
profile 10.1.2.3/24=89012
profile 10.1.2.4/24=34567
profile 12345
cache-max-age 0s
timeout 5s
setup-router false

1 reply

null
    • Failsafe
    • 5 mths ago
    • Reported - view

    Is this a typo?

    profile 10.1.1.1/24=12345
    profile 10.1.2.1/24=45678
    profile 10.1.2.3/24=89012
    profile 10.1.2.4/24=34567

    Based on the listeners you created, it seems the profiles should instead be:

    profile 10.1.1.0/24=12345
    profile 10.1.2.0/24=45678
    profile 10.1.3.0/24=89012
    profile 10.1.4.0/24=34567

    Also, I would highly recommend setting the following as:

    log-queries false
    cache-size 10MB
    

Content aside

  • 5 mths agoLast active
  • 1Replies
  • 44Views
  • 2 Following