0

OpenBSD installer not working

After a bunch of issues setting things up using CoreDNS and getting DoT to work (it did in the end, to be fair it was me being an idiot) ... I decided to give the NextDNS proxy a try. I followed the instructions listed for OpenBSD on the wiki, and got this ... 

% doas sh -c 'DEBUG=1 sh -c "$(curl -sL https://nextdns.io/install)"'

INFO: OS: openbsd
INFO: GOARCH: arm64
INFO: GOOS: openbsd
INFO: NEXTDNS_BIN: /usr/local/sbin/nextdns
INFO: INSTALL_RELEASE: 1.37.4
DEBUG: Start install loop with CURRENT_RELEASE=
DEBUG: NextDNS is not installed
i) Install NextDNS
e) Exit
Choice (default=i):
INFO: Installing NextDNS...
DEBUG: Using bin install type
DEBUG: Installing 1.37.4 binary for openbsd/arm64 to /usr/local/sbin/nextdns
DEBUG: Downloading https://github.com/nextdns/nextdns/releases/download/v1.37.4/nextdns_1.37.4_openbsd_arm64.tar.gz
DEBUG: Start configure
DEBUG: Get configuration ID
NextDNS Configuration ID: xxx
DEBUG: Add arg -config=xxx
Sending your devices name lets you filter analytics and logs by device.
Report device name? [Y|n]: y
DEBUG: Add arg -report-client-info=true
Accept DNS request from other network hosts.
Setup as a router? (y/n): y
DEBUG: Add arg -setup-router=true
Make nextdns CLI cache responses. This improves latency and reduces the amount
of queries sent to NextDNS.
Enable caching? [Y|n]: n
Changes DNS settings of the host automatically when nextdns is started.
If you say no here, you will have to manually configure DNS to 127.0.0.1.
Automatically setup local host DNS? [Y|n]: n
DEBUG: Add arg -auto-activate=false

Congratulations! NextDNS is now installed.

To upgrade/uninstall, run this command again and select the approriate option.

You can use the nextdns command to control the daemon.
Here is a few important commands to know:

# Start, stop, restart the daemon:
nextdns start
nextdns stop
nextdns restart

# Configure the local host to point to NextDNS or not:
nextdns activate
nextdns deactivate

# Explore daemon logs:
nextdns log

# For more commands, use:
nextdns help

% doas nextdns start
doas: nextdns: command not found


% doas rcctl start nextdns
rcctl: service nextdns does not exist

% ls -l $(which nextdns)
-rwxr-xr-x  1 root  wheel  0 Nov 25 12:21 /usr/local/sbin/nextdns

 

So, the result is no service installed (as is the norm on OpenBSD) and an empty script/binary which obviously does nothing. 

I've tried running the command in a root shell as well, to no avail. 

What am I doing wrong?

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Looking at the install script, I see

    asroot() {
        # Some platform (merlin) do not have the "id" command and $USER report a non root username with uid 0.
        if [ "$(grep '^Uid:' /proc/$$/status 2>/dev/null|cut -f2)" = "0" ] || [ "$USER" = "root" ] || [ "$(id -u 2>/dev/null)" = "0" ]; then
            "$@"
        elif [ "$(command -v sudo 2>/dev/null)" ]; then
            sudo "$@"
        else
            echo "Root required"
            su -m root -c "$*"
        fi
    }

     

    which I am not sure will work as intended on OpenBSD?

    Like
Like Follow
  • 2 days agoLast active
  • 1Replies
  • 19Views
  • 1 Following