1

iOS app failing to work.

iPhone 6s iOS 13.7


Since Thursday 2nd June at around 5:30 am BST (British Summer Time) the NextDNS app on my iPhone suddenly stopped working, after months of no problems. 
I have tried all the troubleshooting steps, like removing the vpn profile, rebooting my device, even uninstalling the app completely then rebooting and reinstall the app. I have not found any logs or error messages for the app anywhere. 
There has NOT been any changes to my setup as I have turned off automatic updates for the system. 

Android app version appears to be not affected, only the app on my iPhone is not working. 

From what I can tell it appears to not setup a functioning local vpn (tunnel interface), dns requests fail until the system falls back to default dns lookups. I cannot think of why it has suddenly stopped being able to do this as other apps are able to do so, without problems. 

Could it be something that changed at NextDNS?

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Same issues iPhone 6S & iPhone SE iOS 12

    Like
      • R P M
      • R_P_M
      • 5 mths ago
      • Reported - view

      BigDargon 

      I found an alternate DoH app to use on iOS but it has an annoying issue of looking up IPv6 addresses even though IPv6 is not available. As a result for one domain lookup there are two dns requests. 
      Anyway, if you’re still interested, the name of the app is “Morhill DoH Switcher” and works on iOS 11+

      Like
      • R P M
      • R_P_M
      • 5 mths ago
      • Reported - view

      Further on Morhill DoH Switcher has now stopped doing IPv6 lookups. Seems to be working without issues now. 

      NextDNS app still broken. 

      Like
      • BigDargon
      • BigDargon
      • 5 mths ago
      • 1
      • Reported - view

      R P M Currently, in iOS 12 or earlier I use Adguard Pro to use DoH of nextdns. Use it temporarily while waiting for nextdns to fix it!

      Like 1
  • An update on this, just tried the app again (out of curiosity) and it appears to be back to working normally. Weird!
    One oddity is the device ID has changed, may be linked to reinstalling the app after troubleshooting the failure before. I might reinstall again to check this theory. 

    Edit: Just reinstalled the app and indeed the device ID has changed. Who knew. 

    Like 1
      • BigDargon
      • BigDargon
      • 4 mths ago
      • Reported - view

      R P M Thank you for the update!  I tried reinstalling and it worked!  Hopefully the future won't be broken anymore!

      Like
Like1 Follow
  • 1 Likes
  • 4 mths agoLast active
  • 6Replies
  • 158Views
  • 2 Following