0

Did NextDNS profiles stop working on MacOS 14 Sonoma?

Noticed that some sites were utterly overloaded with ads this morning, went to check with my.nextdns.io.
The site keep telling me

This device is using NextDNS with no profile.
Make sure to link your IP address in the Linked IP section below.

even though the IP clearly is linked, it's diplayed with a green star to its right and it's the correct current IP assigned to my router (checked with whatsmyip). Creating and installing a new profile does not change anything, only by starting and enabling the NextDNS app can I get to «All good!».

Disabling «Use advanced tracking and fingerprint protection» in Safari (my main browser) doesn't change anything.

Do these profiles need to be activated somehow, and if so, how or where?

8 replies

null
    • NextDNs
    • 9 mths ago
    • Reported - view

    In case you are using chrome, please make sure private DNS is disabled from the browser settings.

      • Sen
      • 9 mths ago
      • Reported - view

       On my system the secure DNS option in Chrome (117.0.5938.149) and Edge (117.0.2045.47) had no effect on whether they observed the profile I generated with apple.nextdns.io.

      With the setting enabled and disabled, the NextDNS Setup page showed that Chrome and Edge were using the profile configured on my router, that profile does not have Block Bypass Methods enabled.

      I had to manually set enter profile in both browsers as a customised provider with the DoH URL (https://dns.nextdns.io/NDNSID/DeviceID), unfortunately that's not ideal as I have to use numerous profiles in both browsers for my work.

      On the other hand, I had no issues with Safari (17.0).

    • Phil_Bee
    • 9 mths ago
    • Reported - view

    No Chrome, I'm on Safari 17.0.

      • Sen
      • 9 mths ago
      • Reported - view

       In case you're still looking for where Profiles are enabled and such, there are a few places to check.

      To check what profiles are on your system, go to: System Settings> Privacy & Security> Profiles (it's right down the bottom).

      To check whether a profile that has network settings is enabled, go to: System Settings> Network> VPN & Filters

      • Phil_Bee
      • 9 mths ago
      • Reported - view

       Hey, thanks a lot, that's a start!
      I now can see that there's

      • 1 NextDNS profile in Settings > Privacy > Profiles and
      • 2 NextDNS profiles in Settings > Network > VPN.

      However, I can't seem to activate any of this anywhere, the 2 profiles in Network > VPN are greyed out.

      All of which is not very convincing – there's no way I could even start to explain any of this to my family.

      • Sen
      • 8 mths ago
      • Reported - view

      , pardon me, completely missed the email notification.

      While they do list Profiles as the preferred configuration method for users on Apple devices, I've found my clients preferring the apps as they have a more visible control in the menu bar/app itself. Part of my day job is diagnosing networking issues, so I'm used to the Profile futz.

      From your screenshots I see that you've got both a Profile installed and the app.

      If you want to use Profiles, your first screenshot is correct, it should only show one there and the only thing you can do with it there is to delete it. With the Profile showing in Privacy> Profiles, you should only see one entry in Network> VPN & Filters> Filters & Proxies.

      That you have a NextDNS entry in the VPN & Filter section and two entries in the Filters & Proxies section means that you have the app installed along with potentially two Profiles. Try deleting the Profile from the Privacy section, then if there are none in Filters & Proxies you can then install a new/fresh Profile and enable it in Filters & Proxies, or you can enable NextDNS in the app/menu bar and the NextDNS entry in the VPN & Filter section will show as enabled.

      • Phil_Bee
      • 8 mths ago
      • Reported - view

       Thanks a bunch for this information!
      I've now disabled and deleted everything I found / was deleteable in System prefs, and enabled the app.
      Internet has been a bit wonky in the last few days, with some noticeably slow server lookups. The app makes it easier to disable NextDNS and see if it's just an issue with their service or if it's on the server side.
      A good thing is that if NextDNS stops working for whatever reason, it's pretty easy to notice, as suddenly all or most websites become almost unusable behind all the ads junk.

    • Usama_Karim
    • 7 mths ago
    • Reported - view

    After all these setups, NextDNS was still not working on my Chrome Browser on Mac. Chrome's Async DNS resolver is the reason.

    I found this setup from saneef on Reddit:

    Write these commands in your terminal and restart your browser

    For Chromium

    defaults write org.chromium.Chromium BuiltInDnsClientEnabled -boolean false

    For Google Chrome

    defaults write com.google.Chrome BuiltInDnsClientEnabled -boolean false

    For Arc Browser

    defaults write company.thebrowser.Browser BuiltInDnsClientEnabled -boolean false

Content aside

  • 7 mths agoLast active
  • 8Replies
  • 1028Views
  • 4 Following