0

CLI NextDNS version not managing all DNS queries

Hello Forum,

I have the NextDNS CLI client on a Debian server linked with my internal PowerDNS DNS server,  The NextDNS CLI software is on port 53 and receives all DNS queries.  If the query is for an internal entry, the NextDNS CLI passes the query to PowerDNS but for external queries, it passes it out to  NextDNS to handle.

All my devices have the Debian server IP address, port 53, as their DNS entry. And for most devices, if I log on to NextDNS.io from the device, I can see the green spot and the "All good! This device is using NextDNS with this configuration." message.

But some devices such as my iPhone, even though the DNS configuration is correct, when I log on to NextDNS.io from the device I get the red spot and the message stating "This device is not using NextDNS. This device is using " (a n other)" as DNS resolver."

How do I diagnose this so that all devices connected to my network and DNS server are using NextDNS?

Thank you.

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello Forum,

    Please ignore this post.  I just found a similar question posted a week or so ago and it pointed me to the answer.

    The issue arises from using the "iCloud Private Relay" setting, which I believe operates as a VPN meaning, AFAIK, the DNS queries are being passed through to the VPN server not via my internal DNS server.

    Thank you to anyone who had previously considered responding.

    Like
Like Follow
  • 1 mth agoLast active
  • 1Replies
  • 77Views
  • 1 Following