0

Chat services at&t galaxy s22 don't work.

When sending a video or picture I see the request go out for " ftcontentserver.rcs.mnc410.mcc310.pub.3gppnetwork.org " but my content never sends. If I disable "private dns" the message content sends. Only occurs on mobile network with private dns enabled (wifi enabled works). I'm concerned "ftcontentserver.rcs.mnc410.mcc310.pub.3gppnetwork.org"is not in NextDNS name records.

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • This can happen if you have DNS Rebinding protection enabled. AT&T uses private IPs for some of their services. Try allowlisting the domain or disabling rebind protection and see if that doesn’t help. 

    Like
  • Checked the setting is off I've never used it. I've added the ftcontentserver.rcs.mnc410.mcc310.pub.3gppnetwork.org to the allow list with no luck. I even tried DNS rewrite to point to the IP reported by Google DNS, with no luck.

    Like
    • Daniel Interesting..I’ve had to do a rewrite in the past too but not sure why it’s not working for you. Sorry i couldn’t be of more help. 

      Like
      • Greg B.
      • nisten
      • 9 days ago
      • Reported - view

      Daniel have you searched "rcs" or "ftcontentserver" in your logs to see if there's any other subdomains? if there are, then you may need to truncate to a shared/geo root subdomain when whitelisting

      Like
      • Daniel
      • Daniel.4
      • 8 days ago
      • Reported - view

      Greg B. Only thing in the logs is ftcontentserver.rcs.mnc410.mcc310.pub.3gppnetwork.org, This is pic when connected to my pihole via wifi, gets answered and pic/videos send.

      Like
      • Greg B.
      • nisten
      • 7 days ago
      • Reported - view

      Daniel are you trying to use pi-hole in conjunction with NextDNS?

      Like
      • Daniel
      • Daniel.4
      • 7 days ago
      • Reported - view

      Greg B. No I normally use nextDNS on my phone via "Private DNS" . I'm just showing that RCS works via wifi with a dns adblocker (pihole) and "private DNS" enabled or disabled (NextDNS). This is the only server it tries to reach and it works on my pihole via wifi. Girlfriend's phone hits the same server and she gets the message (both on wifi). Here's a screenshot on wifi (private DNS off) right after I hit send only address is the ftcontentserver.rcs.mnc410.mcc310.pub.3gppnetwork.org. Maybe the private DNS setting breaks ATT RCS, I'm at a loss. 

      Like
Like Follow
  • 7 days agoLast active
  • 7Replies
  • 47Views
  • 3 Following