1

SmartDNS config

Recent versions of dd-wrt have SmartDNS, and I'm looking to configure nextdns with it. I've tried server-tls 45.90.28.0:853 -host-name: xxxxx.dns1.nextdns.io and it works for DNS resolution, but nextdns reports that I'm using a different configuration.

 

Is there some setting that needs to be added? 

4 replies

null
    • in_addr_arpa
    • 1 yr ago
    • Reported - view

    Is your computer using your router as it's the DNS resolver? What OS and version are you running?

      • sunny0_0
      • 1 yr ago
      • Reported - view

      in-addr. arpa yes. To test I used settings from the setup page in dnsmasq on my router, and NextDNS reported it working on my computer. I also disabled WAN DNS in both cases. But since it reported that I was using NextDNS with another configuration when using SmartDNS, it seems that the problem is that my ID is not recognized. I would use dnsmasq but I want tls. 

      Anyway... I'm using opensuse tumbleweed. 

      Edit: perhaps what I need is the equivalent of no-resolv in dnsmasq but for SmartDNS. 

    • FruitFucker2000
    • 1 yr ago
    • Reported - view

    Yes, I too would like to use DDWRT's smartDNS implementation with DOT/DOH.

    The current DNSMASQ script in the setup only enabled DNSSEC but not DOT/DOH..

    • Pot_Leaf
    • 1 yr ago
    • Reported - view

    I can get DOH to work I cant get DOT to work

    DOH: server-https https://45.90.28.0/xxxxxx/name%20of%20device
    server-https https://45.90.30.0/xxxxxx/name%20of%20device

Content aside

  • 1 Likes
  • 1 yr agoLast active
  • 4Replies
  • 581Views
  • 4 Following