0

Wow, hard to believe, problems on a MAC

Been using NextDNS for about 6 months now via NextDNS DNS server IP's in my router config, and have a new message when I go to my.nextdns page:

This device is using NextDNS with no configuration.

Make sure you use the DNS-over-HTTPS endpoint shown below.

Okay, so I'm easy, I'll try anything :-).

My first try was to add and validate the NextDNS profile on my mac. Did that, rebooted my computer, same message as above. So I removed the profile and tried the NextDNS app from the app store. Installed and put in the macOS custom configuration string. Enabled and have it turned on at system startup. Rebooted my mac, same message as above.

I should add that my mac is an M1-based Mac Mini, pretty new. Using macOS Big Sur 11.2.1. I'm assuming that NextDNS works on M1-based mac's, but apparently that's a big assumption to make.

Any ideas on how to actually get encrypted DNS before I resort to Cloudflare?

Thanks!

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • What does https://test.nextdns.io say?

    Like
  • Good question:

    {
    "status": "ok",
    "protocol": "DOH",
    "client": "xx.xx.xx.xx",
    "destIP": "104.238.181.28",
    "anycast": false,
    "server": "vultr-sjc-1",
    "clientName": "chromium-default"
    }
    

    That looks better than the message that I'm getting.

    So do you think that I should ignore the message, or is there something further that I need to do?

    Thanks!

    Like
  • I do get the same test output with the NextDNS mac app enabled or disabled. Wonder if it's doing anything, then?

    Like
  • I've now decided that the router is doing all the work here, and I don't need configuration stuff on my mac after all...doesn't seem to affect the final result, anyways. 

    So I guess I'll just get rid of the NextDNS mac app, ignore the message, and be happy :-).

    Like 1
    • MrDoh you probably have DoH setup at the Chrome level. Please make sure you disable DoH there.

      Like
      • MrDoh
      • MrDoh
      • 1 yr ago
      • Reported - view

      Olivier Poitrey Interesting, I'll do that. Thanks!

      Like
      • MrDoh
      • MrDoh
      • 1 yr ago
      • Reported - view

      @Olivier Poitrey Nice, thanks Olivier, that got rid of that weird message, back to looking like it's working.

      Appreciate it!

      Like
Like Follow
  • 1 yr agoLast active
  • 7Replies
  • 195Views
  • 3 Following