0

For some reason, NextDNS website is taking 20-30 seconds to load for me, but only when I use DNS-over-HTTPS in Firefox

I use the DoH feature in Firefox. When I disable it, it loads fine. In Firefox's developer tools it says that this delay is happening in the DNS resolution stage of api.nextdns.io. This started happening since some weeks ago. All other sites are loading fine. Despite this, the DoH in YogaDNS seems to be working with no problem. 

Can the devs take a look on this? Is anyone else facing this problem?

(I originally posted this on Reddit, I'm reposting here for a better visibility to the devs.)

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Did you test another browser like Edge or Chrome?

    Like
      • jow
      • jow
      • 13 days ago
      • Reported - view

      DynamicNotSlow I tried to test it on Chrome, I copy-pasted the URL provided in my NextDNS config's Setup page, but I think there's some problem in my Chrome as it doesn't accept NextDNS as a valid provider, it just says "Please verify that this is a valid provider or try again later".

      Like
      • DynamicNotSlow
      • Pro subscriber ✓
      • DynamicNotSlow
      • 13 days ago
      • Reported - view

      jow sounds like a misconfiguration. Reset your browser 

      Like
  • Update: I just found out that this isn't happening only with NextDNS, it's also happening in a few other sites, like this one: www.3ait.co.uk . The only way I've found to workaround this is by adding api.nextdns.io in the about:config setting network.trr.excluded-domains in Firefox, which makes this domain not use DoH, and this way making the site load instantly. This is not a solution, something is wrong somewhere, but at least the delay doesn't happen anymore.

    Like
Like Follow
  • 12 days agoLast active
  • 4Replies
  • 73Views
  • 1 Following