5

impossible connection of private DNS on Google pixel 6

hello, since this morning, it is impossible for me to connect to the nextdns service on my pixel 6 updated with the may patch.  Is there a breakdown?

57 replies

null
    • Reny_Neto
    • 1 yr ago
    • Reported - view

    Hello,
    What was the solution? I'm facing this exact problem on Pixel7. (DOT)

    Adding: It is an intermittent issue. Usually, reproducible when changing the device connection type. (Wifi -> Mobile data)

    • Paolo_Stefani
    • 1 yr ago
    • Reported - view

    I just tried other private DNS providers, as Cloudfare, Google, ControlD, Adguard, but only with Nextdns I have the error.

    • Andy_Serwatuk
    • 1 yr ago
    • Reported - view

    This is still happening for me.  Private DNS setup and intermittently won't work after switching to mobile. 

     

    Samsung S23 Ultra on Bell in Canada. 

    Same problem I was having on my S21 Ultra. 

    As many have mentioned, adguard does not have this problem. 

    • Martin_Anders
    • 1 yr ago
    • Reported - view

    Still not working for me. 

     

    Even my.nextdns.io is not reachable.

     

    If I switch to WIFI, everything is working fine even with private DNS enabled

      • losnad
      • 1 yr ago
      • Reported - view

      Instead of posting the same message multiple times you could have searched the forum.

      Some internet providers are blocking some ports.

      You either change your mobile network, or make a complain to them, or use another DNS protocol. If they block DoT you use DoH or DoQ. The NextDNS app use DoH. There are other app in which you can use any or all protocols.

      https://help.nextdns.io/t/83h1v8j/vodafone-tr-issue

      • Ken.6
      • 2 mths ago
      • Reported - view

      I was running into this same issue on iOS. Not sure if this will help you, but wanted to put it out there in case it helps someone else.

      My symptoms were the same. Sites loaded while on WiFi, but switching to my cell connection (T-mobile, I believe they use IPv6) resulted in sites unable to load. I couldn't find anything that would load.

      After disabling the "Use Ultra-Low Latency Network" setting in the NextDNS app, everything started working again. I can't say what networking magic was going on behind the scenes. I'm also not sure how you would go about this without using the dedicated NextDNS app.

    • Darren.1
    • 2 wk ago
    • Reported - view

    I am experiencing this issue on my Android phone, when using Boost/Telstra Australia cellular connection.

    NextDNS is working fine on this phone when I'm connected to my home WiFi - my.nextdns.io reports my phone is using NextDNS with this profile.

    But as soon as I disable WiFi and switch to 4G, my.nextdns.io fails to resolve or connect.

    Strange thing is, some websites such as google.com work. I can do a live google search and open (some) results.

    If I try go to forbes.com it fails to resolve/connect - but works fine on same phone when using home WiFi connection.

    Perhaps my mobile carrier is blocking DNS-over-TLS/QUIC ?
    But why do some websites open ?

Content aside

  • Status Solved
  • 5 Likes
  • 2 wk agoLast active
  • 57Replies
  • 2048Views
  • 21 Following