1

EdgeOS Nextdns CLI stop working

Context:

- Nextdns CLI 1.38.0

- Platform: EdgeOS

- Hardware: Edgerouter X (firmware EdgeRouter X v2.0.9-hotfix.5)

- Diag result: https://nextdns.io/diag/a5150a80-90ea-11ed-91f8-e5aeb9f0fab3

 

I just realised last night, "nextdns cli" stopped working as it route to anycast DNS. 

I managed to stop and restart -> no luck

Refresh (remove and add profile) -> no luck

Directly add customised nextdns over Chrome browser -> ok, works 

 

A few event on attached screenshot.

QQ: 

1. Is there any config changes on nextdns or service down that we dont know?

2. From the log event, is that normal behaviour? couple times connected to the same address for less than 10minutes

3. Should I reinstall nextdns cli (hope not :D)

10 replies

null
    • Jaka
    • 1 yr ago
    • Reported - view

    Anyone @here from nextdns team? Please let me know if you need more time to look for the answer, that would be great compare to MIA

    • NextDNs
    • 1 yr ago
    • Reported - view

    From your test report, it seems to be working. CLI may use anycast, it does not mean it is not working.

      • Jaka
      • 1 yr ago
      • Reported - view

      NextDNS why it use anycast while the dedicated address available and ping are on lower than anycast? 

       

      Your answer not going to answer my question sorry

      • R_P_M
      • 1 yr ago
      • Reported - view

      Jaka You can set the CLI to only use ultralow by using the forwarder setting in the config. 
      See “nextdns config set help” for the details. 

      • NextDNs
      • 1 yr ago
      • Reported - view

      Jaka what do you get for: curl https://dns.nextdns.io/info --connect-to ::45.114.118.156

      • Jaka
      • 1 yr ago
      • Reported - view

      NextDNS curl -> goes to dediserve-jkt, but the ping result goes to anycast

      aruna@EdgeRouter-X-5-Port:~$ curl https://dns.nextdns.io/info --connect-to ::45.114.118.156

      {"locationName": "🇮🇩 Jakarta, Indonesia", "pop": "dediserve-jkt", "rtt": 2960}aruna@EdgeRouter-X-5-Port:~$

      • Jaka
      • 1 yr ago
      • Reported - view

      NextDNS I did to set the forwarder to 45.114.118.156 (works perfectly) - Anyhow to revert to a default address, say when I moved around the region (Singapore, Malaysia, Bangkok). 

      nextdns config set -forwarder https://dns.nextdns.io#45.114.118.156
      
      • Jaka
      • 1 yr ago
      • Reported - view

      (updated Jan 14, 2023) - I wanted every request has log, and the command I use: 
       

      sudo nextdns config set -forwarder https://dns1.nextdns.io/{myNextDNS ID}/{MyRouterName}
      

      Thanks @r_p_m and @nextdns

    • Jaka
    • 1 yr ago
    • Reported - view

    to edit the nextdns config:

    1. access your nextdns.conf from /config/nextdns/nextdns

    2. edit your nextdns.conf 

    sudo nextdns config edit

    3. how to edit files in Linux

    - Press the ESC key for normal mode.
    - Press i Key for insert mode.
    - Press :wq! Keys to save the updated file and exit from the editor.
    OR
    - Press :q! keys to exit from the editor without saving a file.
    
    
    • NextDNs
    • 1 yr ago
    • Reported - view

    This problem has been fixed.

Content aside

  • Status Fixed
  • 1 Likes
  • 1 yr agoLast active
  • 10Replies
  • 575Views
  • 3 Following