Problem resolving a name in Firefox 85

Have been using NextDNS for months on Firefox using NextDNS URL: https://dns.nextdns.io/xxxxxx/ret%20ret

Where "xxxxxx" is my ID

I just upgraded from Firefox 81 to Firefox 85. Most name resolutions succeed, but the following fails:


Firefox 85 returns the following error:

Unable to connect
Firefox can’t establish a connection to the server at r20.rs6.net.

The only way I can get this to work is to change the NextDNS URL to: https://dns.nextdns.io

But this doesn't allow me to use my ID.

I've also tested and can confirm the problem does not occur with Firefox 81 when using NextDNS URL: https://dns.nextdns.io/xxxxxx/ret%20ret

Since the resolution problem on Firefox 85 so far only happpens for the above URL, I'm suspecting the problem is related to the length of the URL.

Please let me know if you need additional information.

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Update: after more testing, it seems that simply trying to resolve "r20.rs6.net" fails unless the ID info is stripped off in the TRR settings for Firefox 85. Doesn't happen for Firefox 81.

    OS is Windows 10 9104.

  • Do you have network.trr.mode set to 3?

    I wanna say that ttr mode 3 is relatively new for NextDns, in which case you'll need to follow steps 5 & 6 of the firefox browser setup if you haven't done so already

  • Yes, I have tried network.trr.mode set to 3. I can still only get NextDns to resolve "r20.rs6.net" if I use https://dns.nextdns.io  (ie, without the my assigned unique identifier, which does not allow me to use my customized setup.

  • I have just completed additional testing in a virtual machine with both Firefox 81.0 and 85.0.2. The tests were performed with NextDNS URL: https://dns.nextdns.io/xxxxxx/ret%20ret where "xxxxxx" is my NextDNS ID.

    I first tested with Firefox 81.0. I then upgraded it to 85.0.2 and tested again.

    Firefox 81.0

    Firefox 85.0.2

    The only way I can get NextDNS to work in Firefox 85.0.2 is to change the NextDNS URL to https://dns.nextdns.io. This works for either network.trr.mode (2 or 3), but it prevents me from using any customization.

Like Follow
  • 2 mths agoLast active
  • 4Replies
  • 57Views
  • 1 Following