1

Ultra-Low Latency Issue

I believe I’m having an issue with Ultra-Low Latency on version 2.0.1 of the app running on iOS 14.3. At random, all DNS requests stop replying (unable to ping anything). If I toggle Ultra-Low Latency off and then back on in the app, everything returns to normal.

29replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Did this happen when you changed network?

    Like
    • Romain Cointepas Appreciate the reply! So far, in my brief testing, I only notice this on my home network. When connecting to 5G/LTE things seem to work fine. It seems like this issue happens when I wake my iPhone up and start browsing. I’m using eero’s for my home network with Spectrum internet.  Any other ideas? Thanks. 

      Like
    • Josh Chandler can you turn off the NextDNS app (with the big switch), connect to your home network and try opening http://dns.nextdns.io (note the http not https). I’m suspecting that something on your network is blocking dns.nextdns.io.

      Like
    • Romain Cointepas I turned it off and was able to successfully go to that URL in my browser and also ping it.

      Like
    • Romain Cointepas One more thing. I have NextDNS DNS IP’s from a configuration in my NextDNS account also used on my router. Could there be a conflict of some sort when used on the router (using linked IP) and also being used on my iPhone with Ultra-Low turned on?

      Like
    • Josh Chandler Ok, that is weird. You mentioned "unable to ping anything", are we still talking about iOS here?

      Like
    • Romain Cointepas Yes, using the app Net Analyzer. I’ve posted this on Reddit (https://reddit.com/r/nextdns/comments/kyxw0o/ultralow_latency_issue/) and it seems like a person or two may be seeing the same issue as well. Like I said, turning Ultra-Low Latency OFF fixes the issue so I’ll leave it off for now.

      Like
    • Josh Chandler I mentioned the only cause we are aware off in that comment:

      https://www.reddit.com/r/nextdns/comments/kyxw0o/ultralow_latency_issue/gjnnrsa

      What you are seeing is definitely weird and we would really like to get to the bottom of it.

      Could you tell me if you're also having issue pinging an IP (like 1.1.1.1) through that app? That should bypass DNS entirely and not be affected by NextDNS at all.

      Like
    • Romain Cointepas I turned Ultra-Low to ON in the app, waited about 8 minutes until DNS requests stopped responding and then went to the Net Analyzer app and successfully pinged 1.1.1.1 and 8.8.8.8. Toggling Ultra-Low OFF to ON or OFF made DNS to start responding again. Also, it seems if you wait a period of time (45 second to a minute) DNS will start responding again without toggling Ultra-Low or turning it OFF. However, in another 5-10 minutes it will happen all over again with DNS not responding. 

      Like
    • Josh Chandler Got it thanks.

      One more debug flow that would help: could you try Ultra-Low Latency Network turned on with the 3 setups below and report back if it works or not for each one?

      1. 45.90.28.0 and 45.90.30.0 set up on your router (those are our "no-configuration" IPs, it doesn't need any linking, you can just set them there).

      2. 1.1.1.1 and 1.0.0.1 set up on your router (this is cloudflare)

      3. No DNS set up on your router (so it should use your ISP DNS)

      Like
    • Romain Cointepas Do you have no configuration IPv6 addresses that I could also add?

      Like
    • Josh Chandler 

      1. 2a07:a8c0:: and 2a07:a8c1::

      2. 2606:4700:4700::1111 and 2606:4700:4700::1001

      FYI for later, if your home network supports IPv6 then you should ONLY use that (and you wouldn't have to link your IP at all). IPv6 DNS is unrelated to "IPv6 internet", you will still resolve IPv4 and v6 for domains with only IPv6 DNS.

      Like
    • Romain Cointepas Thanks for those. Yea, I attempted to only use IPv6 DNS but the eero app wouldn’t let me leave IPv4 primary blank and therefore couldn’t “save” the DNS configuration on the eero router. 

      Like
    • Romain Cointepas OK, so I’m not sure how much this will help but...

      NextDNS: 1 issue of DNS randomly stopped responding.
      Cloudflare: No issues. 
      ISP: No issues.

      I’m really not sure what to think. Maybe since I’m using both IPv4 & IPv6 NextDNS DNS addresses on my router if conflicts with the app/Ultra-Low? I suppose I could turn off IPv6 on my router to check.

      Like
    • Josh Chandler Yep, could you try 1. (NextDNS no-conf) while completely disabling IPv6 for the entire network (not just DNS)?

      Olivier Poitrey Any ideas?

      Like
    • Romain Cointepas I'll try that soon. One more quick thing... I woke my iPhone up and attempted to go to a website in Safari. DNS wasn't responding (Ultra-Low ON), but I had my MacBook on my lap at the same time, which is running NextDNS macOS app and is ENABLED, so I opened Safari and DNS was responding normally. I'm not sure if that rules anything out (maybe rules out the router?), but thought I'd let you know.

      Like
    • Josh Chandler Our macOS app doesn't use the same approach to enforce DNS as the iOS app, that's why it's not impacted by that weird bug.

      Like
    • Romain Cointepas I turned off IPv6 on my router and have yet to see this issue happen where DNS randomly stops responding with Ultra-Low ON. Maybe this is due to the app switching from IPv4 to IPv6 DNS servers with a delay in between the switch? Is that probable? Any other thoughts? Does this help?

      Like
    • Josh Chandler Got it thanks. Could you:

      1. Reenable IPv6 on the router to reconfirm that it fails with "NextDNS no-conf" again?

      2. Share the output of https://dns.nextdns.io/?name=dns.nextdns.io&type=AAAA and https://dns.nextdns.io/?name=dns.nextdns.io&type=HTTPS (the DNS on your router doesn't matter for this one).

      Like
    • Romain Cointepas I did notice it again, but this time it took several hours for it to happen/me to notice. 
       

      Here are the outputs...

      {"Status":0,"TC":false,"RD":true,"RA":true,"AD":true,"CD":false,"Question":[{"name":"dns.nextdns.io.","type":28}],"Answer":[{"name":"dns.nextdns.io.","type":5,"TTL":284,"data":"steering.nextdns.io."},{"name":"steering.nextdns.io.","type":28,"TTL":60,"data":"2602:ff62:181:2d6::"},{"name":"steering.nextdns.io.","type":28,"TTL":60,"data":"2001:19f0:5c01:1ebc:5400:2ff:fece:28ed"}],"Additional":[{"name":".","type":41,"TTL":0,"data":"\n;; OPT PSEUDOSECTION:\n; EDNS: version 0; flags: ; udp: 1220"}]}
      {"Status":0,"TC":false,"RD":true,"RA":true,"AD":true,"CD":false,"Question":[{"name":"dns.nextdns.io.","type":65}],"Answer":[{"name":"dns.nextdns.io.","type":5,"TTL":258,"data":"steering.nextdns.io."},{"name":"steering.nextdns.io.","type":65,"TTL":60,"data":"1 dns1.steering.nextdns.io. alpn=\"h2\" ipv4hint=\"191.96.51.196\" ipv6hint=\"2602:ff62:181:2d6::\""},{"name":"steering.nextdns.io.","type":65,"TTL":60,"data":"1 dns2.steering.nextdns.io. alpn=\"h2\" ipv4hint=\"45.76.16.236\" ipv6hint=\"2001:19f0:5c01:1ebc:5400:2ff:fece:28ed\""},{"name":"steering.nextdns.io.","type":65,"TTL":60,"data":"2 anycast.dns1.nextdns.io. alpn=\"h2\" ipv4hint=\"45.90.28.0\" ipv6hint=\"2a07:a8c0::\""},{"name":"steering.nextdns.io.","type":65,"TTL":60,"data":"3 anycast.dns2.nextdns.io. alpn=\"h2\" ipv4hint=\"45.90.30.0\" ipv6hint=\"2a07:a8c1::\""}],"Additional":[{"name":".","type":41,"TTL":0,"data":"\n;; OPT PSEUDOSECTION:\n; EDNS: version 0; flags: ; udp: 1220"}]}
      Like
    • Josh Chandler We've made some slight changes on our side, could you try again and report back?

      Like
  • Hi all, I would like to chime in here. I noticed today that sites are hanging up while on my wifi network. Running 2.0.1 on iOS 14.3 with “Use ultra low latency network” enabled.

    Disabling this setting, everything appears to work fine. I am connected to Google WiFi and I’ve also noticed an IOS message indicating “This network is blocking encrypted DNS” however even with this message my NextDNS logs are showing traffic as long as “Use ultra low latency network” is disabled and things are working.

    I am curious as to what toggling this setting does under the hood.  Thanks!

    Like
    • James G Hey James, what DNS servers are you using on your router? NextDNS as well or something else?

      Like
      • James G
      • James_G
      • 5 mths ago
      • Reported - view

      Josh Chandler Currently OpenDNS on the router

      Like
      • James G
      • James_G
      • 5 mths ago
      • Reported - view

      I believe I may have determined my issue. My home network level DNS is configured for OpenDNS. When I go to my iOS device settings and set Google DNS (8.8.8.8, 8.8.4.4) manually and try with NextDNS enabled and "Use ultra low latency network” enabled, I have no problems.

      I believe OpenDNS is doing something to block the functionality of the NextDNS iOS app when "Use ultra low latency network” enabled. Disabling this setting seems to work, OR changing my network-level DNS configuration from OpenDNS to another provider seems to be another solution.

      See here for potential explanation.

      Like
    • James G as far as we know, OpenDNS blocking the new HTTPS qtype is not the issue, blocking the "Proxy/Anonymizer" category in OpenDNS is (it includes dns.nextdns.io). Can you try with OpenDNS but without blocking this category and report back?

      Like
      • James G
      • James_G
      • 5 mths ago
      • Reported - view

      Romain Cointepas Thank you for the suggestion, it appears you were correct. I am no longer seeing issues now, and I can see the call to ios.dns.nextdns.io succeed now in the OpenDNS logs. Thanks!

      Like
  • I'm on iOS 14.3 with the latest version of the app and I am experiencing the exact same issues.
    Every day I wake up I can't load any page on my iPhone until I turn off the ultra low latency toggle.
    I'm here if you need any debugging help.

    Like
    • pancakeufo Could you try without the app but with an Apple configuration profile instead (second choice in our Setup guide), and report back?

      Like
Like1 Follow
  • 1 Likes
  • 4 mths agoLast active
  • 29Replies
  • 548Views
  • 6 Following