0

Win10 unidentified network ... no internet access, but it works

Hello, after an indefinite time it happens that win10 signals a total lack of connection, despite that everything works, at least apparently. To restore the network icon, simply enter Internet Network Settings -> Change card options ... right click on nextDNS Adapter ... disable ... right click on nextDNS Adapter ... enable. How can I prevent win10 from reporting the connection failure?  

12replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
      • andriun
      • andriun
      • 4 wk ago
      • Reported - view

      Calvin Hobbes thanks for your reply. I have read the article, but what do you suggest as a solution, should I maybe add the microsoft dns in white list or what else?

      Like
    • andriun you could add the FQDNs of the servers mentioned in the article to your allow list:

      www.msftconnecttest.com
      dns.msftncsi.com

      if your system can’t see those servers, Windows will erroneously claim to not be connected to the internet.
      Others have suggested not using the WindowsSpyBlocker list because it causes problems with Microsoft software. (I don’t personally use Microsoft software  so I don’t have an opinion about the list)

      If I was using Microsoft products I’d do all of the above 

      edit: corrected “can see” to “can’t see”   Big difference!

      Like
      • andriun
      • andriun
      • 4 wk ago
      • Reported - view

      Calvin Hobbes sorry I understand that you do not use Microsoft, but if you could still help me I would be grateful because the situation has not changed. Do you think I need to take some other steps to make the changes to the nextDNS configuration effective? 

      Like
    • andriun that should fix it.   Perhaps your system has cached dns answers ?   Stop/start the network connection should clear the cache.

      can you see log entries for those entries?

      Like
      • andriun
      • andriun
      • 4 wk ago
      • Reported - view

      Calvin Hobbes if you mean the registry yes those entries are there. I have disabled the network card for the provider but nothing has happened yet. I just have to disable the NextDNS one, but so I have to wait some time to see if the problem is solved. So for the moment I thank you for your kindness. 

      Like
    • andriun sorry, I was referring to NextDNS logs, not registry.   The same article cautions against disabling NCSI probes  to fix this problem 

       Caution

      Microsoft does not recommend disabling the NCSI probes. Several operating system components and applications rely on NCSI. For example, if NCSI does not function correctly, Microsoft Outlook may not be able to connect to a mail server, or Windows may not be able to download updates even if the computer is connected to the internet.

      Check your NextDNS logs for lookups to the Microsoft servers 

      Like
      • andriun
      • andriun
      • 4 wk ago
      • Reported - view

      Calvin Hobbes hello, I tried to start some basic network tests and it turns out that the address "dns.msftncsi.com" is not reachable both in apparently absent network conditions and in active network conditions (NCSI active probes and the network status alert), while the "wdcp.microsoft.com" site always is. Which is rather strange when we consider the content of the article you pointed out to me. Also "dns.msftncsi.com" appears in the nextDNS log list as the other address and is not filtered by nextdns. Another strange thing that led me to add the domain "* .microsoft.com" to the white list, is that the site "web.vortex.data.microsoft.com" appeared strangely as blocked. At this point I no longer understand anything, if you can kindly help me I would be grateful. I can add that as a last thing, that the following error appears in the system event list almost at the same time as activating nextDNS "Name resolution timeout for wpad name. No configured DNS servers responded."  

      Like
    • andriun I’m really not sure what else to suggest.  As I mentioned at the beginning I’m not a Windows user.   I was aware of the very common problem and usually adding the allow list entries from the article fixes the problem.   It sounds like there’s more going on in your situation.    Maybe someone else can help. Good luck 

      Like
      • andriun
      • andriun
      • 3 wk ago
      • Reported - view

      Calvin Hobbes Hello, I understand very well your situation and even though the first thanks go to God for how you offered to help me, the second thanks goes to you who behaved like a good Samaritan. If God wills I will have the opportunity to solve through some other support, but to you, as mentioned above, much of my gratitude goes for how you offered yourself (if some parts are not understandable or grammatically wrong, I specifically used google for the translation , because my English is not so perfect as to allow me to forward lines of help of this type).

      Like
  • Please try adding the following reg entry then reboot:

    reg add "HKEY_LOCAL_MACHINE\SOFTWARE\POLICIES\MICROSOFT\Windows\NetworkConnectivityStatusIndicator" /v UseGlobalDNS /t REG_DWORD /d 1 /f
    Like 1
  • Been using NextDNS with the windows app on win 10 for a few days with no issues. Today the same thing happened to me out of the blue. Lost all internet connectivity when the app was active. When I disabled the app/Tap adapter connectivity would resume. Tried uninstalling, rebooting, reinstalling the app and as soon as it would activate network access would completely stop. I ended up having to go into device manager and completely remove the NextDNS TAP adapter. Rebooted and reinstalled the NextDNS app again and the issue was resolved. Seems like something broke involving the TAP adapter. Hope you guys can reproduce this somehow and fix in the next version of the windows app. Thank you and keep up the great work!

    Like
Like Follow
  • 2 wk agoLast active
  • 12Replies
  • 132Views
  • 4 Following