0

Youtube Restricted mode on but I don't have it enabled

Hi,

I'm having problems with Youtube restricted mode. When I visit youtube from my desktop PC the comments are not available and it says the restricted mode is on.

However, I have checked and this setting is not enabled in Youtube nor is it enabled in the "Adults" configuration I have with NextDNS.

I have tried clearing the cache and using a different browser but it still stays on.

 

Some more info. NextDNS is running on my OpenWRT firewall with a few different configurations set up by CLI. The "Kids" config has this setting turned on.

When I use my mobile I don't have the problem. My mobile is using the same "Adults" config as my PC but is not resolving DNS via the router but directly from NextDNS using the private DNS setting withing the Andriod OS.

 

Is anyone able to help me troubleshoot this please?

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Change the DNS config to something other than nextdns. Does the problem go away?

    Like
  • Hi Andrew, I did not know anyone had replied to my original post.

    This morning youtube was working as expected in no-restricted mode.

    When I came back on my machine in the afternoon it had slipped into restricted mode. I bypassed NextDNS by setting 1.1.1.1 as the DNS server on my local machine. 

    When I reload the page youtube is in non-restricted mode again.

    So yes switching away from NextDNS does solve the problem

     

    This is my NextDNS config on OpenWRT

    config nextdns 'main'
        option enabled '1'
        option setup_router '1'
        option report_client_info '1'
        option hardened_privacy '0'
        option log_queries '0'
        option cache_max_age '0s'
        option bogus_priv '1'
        option use_hosts '1'
        option timeout '5s'
        option cache_size '0'
        option auto_activate '0'
        option control '/var/run/nextdns.sock'
        option max_ttl '0s'
        option detect_captive_portals '0'
        list listen 'localhost:53'
        list config '192.168.10.0/24=76####'
        list config '192.168.57.0/24=88####'
        list config '192.168.101.0/24=f7####'
        list config '192.168.69.0/24=91####'
        list config '192.168.99.0/24=28####'

    My machine is on the 192.168.10.0/24 subnet

    Like
Like Follow
  • 1 mth agoLast active
  • 2Replies
  • 67Views
  • 3 Following