0

Nextdns cli install issue

Hi,

i get some troubles when install nextdns cli on my macbook, it notice that "tar: Error opening archive: Unrecognized archive format", you can see more detail in attachment.

Does Anyone can help me to solve this?

Thank you!

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Not sure, but do you have both  Homebrew and Xcode command line tools for M1 installed?  They’re both prerequisites 

    Like
      • Anony
      • Anony
      • 2 mths ago
      • Reported - view

      Calvin Yes i installed both homebrew and xcode

      Like
  • M1 will be supported in the next revision of the cli. For now you can force the amd64 arch by adding GOARCH=amd64 in front of the install command.

    Neither xcode nor homebrew are required for the install BTW.

    Like
      • Anony
      • Anony
      • 2 mths ago
      • Reported - view

      Olivier Poitrey i succesfully installed the previous version 1.10 but when upgrade to the newest version it get this bug. i don't know why?

      Like
Like Follow
  • 2 mths agoLast active
  • 4Replies
  • 57Views
  • 3 Following