0

NextDNS block TpLink Config page

Hello friends, I'm having some problems with my NextDNS Windows client, I have a TP-Link Ex220 router accessible via tplinkwifi.net and for some reason Next blocks access to the page. To access it I need to deactivate NextDNS and close the app.

Does anyone know how I can resolve this?

21 replies

null
    • R_P_M
    • 1 mth ago
    • Reported - view

    It is not “blocked”, NextDNS just doesn’t know the IP address because it’s only a local address. Add a dns rewrite to point that domain to the local IP of your router. 

      • wanderson_braz
      • 1 mth ago
      • Reported - view

       i I created the DNS rewrite but I still have no access when running the Next app for Windows

      • R_P_M
      • 1 mth ago
      • Reported - view

       Could you try, from the command line:

      nslookup tplinkwifi.net
      • wanderson_braz
      • 1 mth ago
      • Reported - view
      • R_P_M
      • 1 mth ago
      • Reported - view

       DNS rewrite appears to be working correctly from that result. I’m not sure why you still can’t access the router with NextDNS on.

      Try pinging the router with NextDNS off and with it on. 

      ping tplinkwifi.net
      • wanderson_braz
      • 1 mth ago
      • Reported - view
      • R_P_M
      • 1 mth ago
      • Reported - view

       

      Are you 100% sure the tp-link IP address is 192.168.0.1 and not 192.168.1.1? 

      • wanderson_braz
      • 1 mth ago
      • Reported - view

        yes 

      • R_P_M
      • 1 mth ago
      • Reported - view

       

      Ok, one last thing to try. Can you access router by IP address?

      http://192.168.0.1

      • wanderson_braz
      • 1 mth ago
      • Reported - view

       

       

      Not directly via IP because it is in AP mode and not router mode, as I do not have access to the operator's modem bridge in this mode, only via link and without next active even though it is running via the yogaDNS app

      • R_P_M
      • 1 mth ago
      • Reported - view

       Ah, ok that’s the problem. In AP mode the TP-Link will have a different IP address. 

      Run the command I gave earlier and write down the IP address you get while NextDNS is disabled. 

      nslookup tplinkwifi.net

      You need to use that IP address for the dns rewrite. That should work after it’s been set. 

      • R_P_M
      • 1 mth ago
      • Reported - view

      After looking over the documentation for yogaDNS I have found a more long term fix.

      You need to add a custom Rule to yogaDNS for the domain tplinkwifi.net and set the option to bypass yoga, that should make it work like NextDNS was disabled but for only that domain.

      • wanderson_braz
      • 1 mth ago
      • Reported - view

       the bypass rule in yoga seems to have worked

      • R_P_M
      • 4 wk ago
      • Reported - view

       That’s great news, hopefully it will persist. 

      • wanderson_braz
      • 4 wk ago
      • Reported - view

      yes yoga bypass rule Works 

    • NextUser
    • 1 mth ago
    • Reported - view

    Getting same problem but with mbb device when I put 192.168.1.1 (router's ip) in firefox or other browser without turning on nextdns in private dns Android it let me access router's webpage but, when I turn private dns on it doesn't let me open router's webpage any solution?

      • R_P_M
      • 1 mth ago
      • Reported - view

       Use a DNS rewrite for domain.

      myzong.mbb.com 192.168.1.1
      • NextUser
      • 4 wk ago
      • Reported - view

      How to use a dns rewrite (and on which device mobile or pc)? I'm new so don't know much

      • R_P_M
      • 4 wk ago
      • Reported - view

      The dns rewrite section is on the settings page of my.nextdns.io near the bottom.
      Put the domain in the top field and the IP address in the second.

      The dns rewrite will work for all your connected devices that are using NextDNS, once it’s been set up in the NextDNS settings.

      (The address is not being blocked by NextDNS because it doesn’t actually know the IP number as it is a local one.)

      • NextUser
      • 4 wk ago
      • Reported - view

      Thank You very much it is working because of U❣️

    • wanderson_braz
    • 3 wk ago
    • Reported - view

    @r_p_m thanks

Content aside

  • 3 wk agoLast active
  • 21Replies
  • 126Views
  • 3 Following