2

Analytics page broken: undefined is not a constructor

Web app becomes unusable after trying to view analytics. Error obscures entire app after page load. New browser window or clear cache is only way to access rest of web app.

Using iPhone, Safari-  iOS 14.4 (18D52)

Error:

undefined is not a constructor (evaluating 'new window.ResizeObserver(n.resizeHandler)')
t@https://my.nextdns.io/static/js/7.c63cdcdc.chunk.js:1:15783
yo@https://my.nextdns.io/static/js/4.f727c150.chunk.js:2:422993
Ui@https://my.nextdns.io/static/js/4.f727c150.chunk.js:2:442480
ju@https://my.nextdns.io/static/js/4.f727c150.chunk.js:2:472272
Su@https://my.nextdns.io/static/js/4.f727c150.chunk.js:2:472200
xu@https://my.nextdns.io/static/js/4.f727c150.chunk.js:2:472063
vu@https://my.nextdns.io/static/js/4.f727c150.chunk.js:2:46902

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Could you (all) refresh https://my.nextdns.io and tell us if the error is still there?

    Like
      • Tom K
      • Tom_King
      • 3 mths ago
      • Reported - view

      Romain Cointepas 

      yes. Getting undefined error after a refresh. Also getting it after clearing all history on iOS Safari and logging back in  

      Analytics is unusable. That used to be a nice service for subscribers. 

      Like
    • Tom K Seems to be an isolated bug. Could you send us the configuration ID with the issue at support@nextdns.io?

      Like
      • Tom K
      • Tom_King
      • 3 mths ago
      • Reported - view

      Romain Cointepas 

      My specific error in the original report seems resolved after follow-up via support email.

      Cleared history & did a log in, and now I can access analytics. 

      Like
  • This is what I'm getting here. Both on my phone and Mac in Safari.

     

    Forgot to mention: For me it started this morning (that's when I first noticed it).

    Like 1
  • I've had the same error since yesterday and it hasn't been fixed for more than a day.
    Interestingly, this error appears in different settings for the same account, but can be seen normally for different accounts.
    It doesn't help because I can't see the logs for the settings I'm using and I can't access the block list with the same error.
    Please recover as soon as possible.

    Like
    • shinglesnowbeam chromeos 88.0.4324.186 Official Build 64bit

      Like
Like2 Follow
  • 2 Likes
  • 3 mths agoLast active
  • 7Replies
  • 72Views
  • 4 Following