1

router.asus.com

Hi,

when changing the dns to NextDns, I am no longer able to browse the router.asus.com. I am not sure if I understand why, it works fine with any standard DNS without me adding it manually.

what can be the issue? why does the domain router.asus.com does not work? and if I need to add the entry manually, how can I add it at NextDns?

Thank you,

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Let me try to explain a little more what I am confused with

    I was using the Asus router with my previous dns provider, and the router.asus.com was resolving to the correct IP of the router, when I switched to nextdns, it does not work anymore.. it might seems obvious since the entry probably does not exist on the nextdns servers, but what get's me confused is that it did not existed in my previous dns provider as well

    So, I guess what makes me really confused is, how it was possible to be working before with my previous dns provider? and if we know the answer, maybe I can replicate it to NextDNS?

    The other question I have is, it is not possible to create a manual DNS entry and NextDNS?

    Like
      • Jörgen
      • Pro Subscriber ✅
      • Jorgen_A
      • 6 mths ago
      • Reported - view

      Miguel It has always worked for me going to router.asus.com when using NextDNS.

      If you do a "ping router.asus.com" from a Command prompt. Does it show the IP-address of the router?

      Like
      • Miguel
      • Miguel
      • 6 mths ago
      • Reported - view
      • Jörgen
      • Pro Subscriber ✅
      • Jorgen_A
      • 6 mths ago
      • Reported - view

      Miguel OK... The next steps I would try:

      1. Run "ipconfig /all" to see what DNS-servers the client use. What does DNS-server say?
      2. Run "nslookup router.asus.com" to see what servers answers to the query. Is your router listed?
      3. Surf to test.nextdns.io and in a browser to see connectivity information.
      4. Does it work on other clients? (Phone, Tablet etc.)

      If you use ASUS Merlin, I would recommend using the NextDNS CLI to handle all DNS-requests. Setup your WAN DNS to 45.90.28.0 and 45.90.30.0 and point all your clients DNS using DHCP to the router.

      Like
      • Rob
      • iOS Developer
      • Rob
      • 6 mths ago
      • Reported - view

      I use the CLI on my ASUS router and it works as expected:

      ➜ nslookup router.asus.com
      
      Name:      router.asus.com
      Address 1: 192.168.1.1

      It should not be needed, but you might be able to use a “rewrite” to work around your issue.

      Like
  • Do you have DNS rebinding protection on?

    Like 1
  • ^ Also check if the domain is being blocked in your logs

    Like
  • Easy fix is go to settings > rewrites. Add router.asus.com and for the target put in your Asus's router ip address. I use opnsense and use unbound dns on my router for lots of local services. In the cli client I have a few customizations the ones I had to do that to let my router handle resolution for local domains was forwader mydomain.com=10.0.1.1:5352 (this is your router's IP) The port 5352 is what I changed my unbound service to answer on. So basically nextdns cli sends the majority of my name requests to the nextdns service, but then I sitll can get my local name resolution I need. I use a different IP for my web services inside than outside.

    So you could put in forwarder router.asus.com=X.X.X.X which would be your router's IP address.

    Like 1
      • Miguel
      • Miguel
      • 6 mths ago
      • Reported - view

      Donato Orlando This was exactly what I was looking for, thank you so much for your help!!

      Like
Like1 Follow
  • 1 Likes
  • 6 mths agoLast active
  • 9Replies
  • 288Views
  • 6 Following