1

PfSense v2.5 >

I was able to successfully install the cli.  Everything is working fine on the LAN side.  My devices name are showing up as expected.

However, Opt1 and the rest has lost their DNS.  So no internet for other networks.  I did some searching and it seems I can't find the right solution.

Does anyone have an idea? 

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • This might be a solution.  Got it from opensense:

    1.  SSH into PFsense, open a shell, and run the following command:

       sh -c 'sh -c "$(curl -sL https://nextdns.io/install)"'

     

    2. Type i for install

    3. Answer the installer questions as you see fit. Have your NextDNS configuration ID handy. 

     

    4. Edit nextdns.conf file and modify the parameters highlighted in the screenshot. 

    vi /usr/local/etc/nextdns.conf

    5. Change setup-router to false

    6. Add a ‘listen‘ line with the Interface IP address of your PFsense firewall, where you point the clients to for DNS, and add a colon 53  (:53) at the end.
    7. Make sure the localhost line is also configured for port 53.

      

    8. Save the NextDNS configuration file (<escape:wq!).
    9.Open the PFsense web GUI, and navigate to: ServicesUnbound DNSGeneral
    10. Untick the Enable Unbound box, if already checked.
    11.  Back in the SSH session, type nextdns restart.

    Like
Like1 Follow
  • 1 Likes
  • 3 days agoLast active
  • 1Replies
  • 51Views
  • 1 Following