0

Conflict w/ NextNDS and Twobird email app (iOS)

I'm using the Twobird email app on my iPhone. I've noticed that, if I have NextDNS enabled, I get an error in Twobird saying that my device is offline. From troubleshooting, I've determined that it has something to do with NextDNS. If I disable NextDNS via the iOS app, Twobird comes back online. I tried using the profile instead of the app, but I'm seeing the same thing. I tried removing all blocklists and disabling all the options for my mobile config on NextDNS, but simply having it turned on causes Twobird to go offline. I can't see any blocked requests in the logs, so I'm at a loss on where to go from here. Oddly enough, I don't see the issue when my iPhone is connected to my home wifi even though my home wifi is configured to use NextDNS as the DNS server. Anyone have any suggestions on where to go from here?

I feel like there is some sort of bug in the iOS implementation due to the seemingly illogical pattern I’ve noticed. I’m going to describe my full setup below, and hopefully someone will see something I’ve missed that could explain what’s happening.


I have three different NextDNS configs set up (Router, Desktop, and Mobile). The Router config is done via NextDNS CLI installed on an old Raspberry Pi, and my eero routers are configured to use that installation as the DNS server. I have the macOS app installed on my Mac mini, and it is set up to use the Desktop config. Finally, I have the NextDNS iOS app installed on my iPhone an iPad, and they are set up to use the Mobile config. As a side note, I’ve also tried using the Apple config profile to see if that resolved the issue, but it did not seem to change anything.


Here’s where things get confusing (at least to me). If my phone is on a cellular connection, and NextDNS is turned on, then I get the “Your device is offline” error message in Twobird. If I’m connected to my home wifi, the error message goes away. Even though the NextDNS iOS app is still turned on, and the NextDNS webUI still confirms the device is using the Mobile config, the issue doesn’t happen when I’m on WiFi. Once I disconnect from WiFi (and don’t change anything else), the error message comes back.
Any idea what about the combination of a cellular connection and NextDNS could be causing Twobird to report being offline? Again, there is literally nothing showing up in the logs that give me any indication of something being blocked.

Reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
Like Follow
  • 1 mth agoLast active
  • 20Views
  • 1 Following