0

Can't upgrade on UnifiOS 1.37.11 NO_PUBKEY

I'm running on 1.37.10 on UnifiOS and if I follow the Wiki steps to upgrade, I'm getting this error. I've tried upgrading before since initial install and it's always the same error.

INFO: Upgrading NextDNS...
Ign:1 http://deb.debian.org/debian stretch InRelease
Hit:2 http://security.debian.org stretch/updates InRelease
Hit:3 http://deb.debian.org/debian stretch-updates InRelease
Hit:4 http://deb.debian.org/debian stretch-backports InRelease
Hit:5 http://deb.debian.org/debian stretch Release
Get:6 https://repo.nextdns.io/deb stable InRelease [8490 B]
Hit:7 https://apt.artifacts.ui.com stretch InRelease
Hit:8 https://apt-release-candidate.artifacts.ui.com stretch InRelease
Hit:9 https://apt-beta.artifacts.ui.com stretch InRelease
Ign:6 https://repo.nextdns.io/deb stable InRelease
Fetched 8490 B in 1s (5675 B/s)
Reading package lists... Done
W: GPG error: https://repo.nextdns.io/deb stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 467A7CCC8ACFA0B7
W: The repository 'https://repo.nextdns.io/deb stable InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.

N: See apt-secure(8) manpage for repository creation and user configuration details.
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  nextdns
1 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 2485 kB of archives.
After this operation, 0 B of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  nextdns
E: There were unauthenticated packages and -y was used without --allow-unauthenticated
ERROR: upgrade: exit 0
 

I found this on Git, but it's not my exact scenario.

Ubuntu Install complains about NO_PUBKEY · Issue #595 · nextdns/nextdns · GitHub

 

# cat /etc/apt/sources.list.d/nextdns.list
deb [signed-by=/usr/share/keyrings/nextdns.gpg] https://repo.nextdns.io/deb stable main

ls -l /usr/share/keyrings/nextdns.gpg
ls: cannot access '/usr/share/keyrings/nextdns.gpg': No such file or directory
 

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Could you try:

    podman exec unifi-os cat /etc/apt/sources.list.d/nextdns.list
    podman exec unifi-os ls -l /usr/share/keyrings/nextdns.gpg
    
    Like
  • My device doesn't have podman installed.

    Like
    • Ryan H OK, my bad. I don't know why you have the right line in `/etc/apt/sources.list.d`, but not the GPG key. You can run:

      (wget -qO /usr/share/keyrings/nextdns.gpg https://repo.nextdns.io/nextdns.gpg ||  curl -sfL https://repo.nextdns.io/nextdns.gpg -o /usr/share/keyrings/nextdns.gpg) &&  chmod 0644 /usr/share/keyrings/nextdns.gpg
      

      Then, the upgrade should work. Maybe something failed with an older version of the install script.

      Like
  • Thank you Vincent, that worked. I'm now on the latest version.

    Like
Like Follow
  • 2 wk agoLast active
  • 4Replies
  • 45Views
  • 2 Following