0

dns over tls nextdns on freebsd

I have a running working config on port 53. I would like to also enable DNS over TLS, so Nextdns also listens on 853.

I tried adding

listen 127.0.0.1:853

and while nextdns restarts and runs, its not actually working.

Netstat is also not showing the port.

How do I do this? I tried searching wiki and knowledgebase but I can't find a clear answer.

 

Thanks!

3 replies

null
    • R_P_M
    • 1 yr ago
    • Reported - view

    Is there a reason why you want to have local DoT? I don’t think that is possible with the CLI currently and it would also require an encryption certificate. 

    • Pipo_de_Clown
    • 1 yr ago
    • Reported - view

    Because I had a host that had hardcoded cloudflare DNS queries flooding my logs (they are blocked).  I wanted to catch and redirect to NextDNS via NAT rule. Turned out that "feature" could be turned off so theres more need.

    Im guessing the certificate can be self signed, I think thats how unbound does it?

Content aside

  • 1 yr agoLast active
  • 3Replies
  • 115Views
  • 3 Following