DNS over QUIC doesn't work anymore


It seems that QUIC isn't working anymore. 



Any idea what's wrong?

19replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • have you tried removing the port at the end?

    Like 1
  • @nisten

    Greg, you do realize that I had no issue before? FYI you should know, if you tried, that it does not work because it is not the right set up.

    Also, there is an issue with QUIC as it is well documented on the web. Many people are complaining about it since a week now.

    I just switched to DoT until NextDNS guys solve the problem.

  • Same issue for me too. I read somewhere it’s because DoQ has now become an official standard and there are some backwards compatibility issues that NextDNS need to implement (Which is why AdGuard DNS quic works but NextDNS no longer does).

    Like 1
  • Make sure you remove the custom port.

      • Aidan Gee
      • Aidan_Gee
      • 2 wk ago
      • Reported - view

      NextDNS unfortunately it no longer works, even without the port number added. It used to work however it appears to have stopped in the last week or so.

  • I’m having the same issue, and also started noticing it in the past 3-5 days. No custom port. I’m wondering if the changes made to support the final DoQ spec server side are related, but have no way of confirming that. I’m willing to help test if needed. 

  • We switched the server to the final implementation of DoQ and the new official port. It should work with an up-to-date version of a DoQ client with no custom port provided.

    • NextDNS I am wondering if the DoQ implementation in the AdGuard mobile apps is out of date now. I know they updated their servers and AdGuard _Home_ to use the latest spec, but the iOS app is a month old, might be using an older version. Wonder if that's the missing piece.

      Like 1
      • Leonard
      • Leonard
      • 13 days ago
      • Reported - view

      Chris Leidich Yes, you need to wait AdGuard Team to update their APP, or you can open the new issue here !

    • NextDNS 

      Did you try what you are suggesting?

      You do realize that no one can get it working with or without the port.

      People are also complaining about this problem on Reddit. You might want to check why it is not working. 

    • Pierre Cartier try forcing the port to 853, seems like the AdGuard iOS application still have an old version of DoQ with the old standard port.

      Like 2
    • NextDNS Port 853 works. Cheers. 

      BTW DoH3 disappeared...

    • NextDNS This works for me too - thanks!

  • Can confirm, DoQ stopped resolving about 2 weeks ago in the middle of the day. Switched to DoH and working normally.

    Not working for me via Adguard Home. Seeing reports of iOS users with same issue.

    Like 1
    • Ryan Likewise 

      • Patrik Kro
      • Patrik_Kro
      • 12 days ago
      • Reported - view

      Ryan DoQ to NextDNS servers is working again with AdGuard Home. NextDNS developers have updated the servers.

    • Patrik Kro As mentioned on the other post only with port 853 vs 8853

  • Official response by AdGuard here:

    "AdGuard DoQ protocols will be changed to the new version in the next update. The best solution right now is to force port 853 manually."

    Like 1
  • It appears to be working with AdGuard now. Something to note that took me a minute.

    When inserting the DNS server, my keyboard capitalizes the first letter.

    If I entered Quic:// upstream test would fail.

    If I enteted quic:// upstream test was successful.

    It appears to be case sensitive.

Like2 Follow
  • 7 days agoLast active
  • 19Replies
  • 439Views
  • 8 Following