0

SmartDNS config

Recent versions of dd-wrt have SmartDNS, and I'm looking to configure nextdns with it. I've tried server-tls 45.90.28.0:853 -host-name: xxxxx.dns1.nextdns.io and it works for DNS resolution, but nextdns reports that I'm using a different configuration.

 

Is there some setting that needs to be added? 

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Is your computer using your router as it's the DNS resolver? What OS and version are you running?

    Like 1
      • sunny0_0
      • sunny0_0
      • 2 wk ago
      • Reported - view

      in-addr. arpa yes. To test I used settings from the setup page in dnsmasq on my router, and NextDNS reported it working on my computer. I also disabled WAN DNS in both cases. But since it reported that I was using NextDNS with another configuration when using SmartDNS, it seems that the problem is that my ID is not recognized. I would use dnsmasq but I want tls. 

      Anyway... I'm using opensuse tumbleweed. 

      Edit: perhaps what I need is the equivalent of no-resolv in dnsmasq but for SmartDNS. 

      Like
Like Follow
  • 2 wk agoLast active
  • 2Replies
  • 90Views
  • 2 Following