NordVPN - Certificate Issue

Does anyone get the same error when starting the NordVPN App in W11? I've set a customized DNS configuration in the app, and recently I'm getting those certificate errors. Any ideia on how to solve this question?

Thanks in advance for suggestions.

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
      • chg_1990
      • Candido_Grasel
      • 1 yr ago
      • Reported - view

      losnad importing the certificate worked fine. Thanks ;)

  • If that appears then you have HTTPS blockpage enabled, but since you are trying to use NordVPN it should NOT appear at all. So that means your NextDNS config or one of it's blocklists is blocking NordVPN.

    you should temp enable your logs, try again and then see what the logs report as the cause of the block.

    Iosnad's comment will make the NextDNS Root CA trusted but not solve your problem however.

  • Hi chg_1990, I think your NextDNS configuration blocked the NordVPN server.

    So a blockpage appeared. Blockpages uses the NextDNS Root CA so that you use HTTPS to see the blockpage.

    Or that's what I think happened.

     To fix that, you need to go to check if in the logs there is anything of NordVPN blocked.

    Also check if the "Block Bypass Methods" in the "Parental Control" section is enabled, what that do is to block ways to bypass your NextDNS configuration.

    When you use NordVPN you are using NordVPN's DNS server so the "Block Bypass Methods" blocks NordVPN servers.

    I hope I helped someway, and let me know!

  • Hello everyone. My logs are active, but I didn't see anything related to NordVPN beeing blocked by any of the block lists. Also, parental controls are all disabled.

Like Follow
  • 1 yr agoLast active
  • 5Replies
  • 137Views
  • 3 Following