3

Public WiFis / Airplane WiFi / Hotel WiFis / Captive Portal WiFis

Couldn't find a clear solution to this, but when connecting to a public wifi or anything that has a captive portal, NextDNS will make connecting to that WiFi impossible, any site (neverssl.com) will just load enlessly. I have to go into the app and whitelist that network for the captive portal to show up and let me login

DNS Rebinding Protection is disabled already. Using the NextDNS app on my iOS devices 

Is there no good way to have NextDNS play nicely with those networks? It's a reason why I can't use the configuration profiles, because without a quick way to switch NextDNS off, I wouldn't be able to use the majority of public wifis that rely on captive portals 

13 replies

null
    • Ugendar_V
    • 1 yr ago
    • Reported - view

    Hi NextDNS support team, 

    can anyone respond on this Captive portal issue. facing lots of issue with client's wifi. Everytime i have to stop the service and let them connect to the wifi and then again turn on the service

      • Junaid_Ahmed
      • 5 mths ago
      • Reported - view

      cmd

    • Paul_Riverside
    • 1 yr ago
    • Reported - view

    Any updates? I have this same issue on most public wifi that requires a sign-in agreement. I have also tried switching to auto DNS setting to sign in, and then switching back to NextDNS afterwards, but this causes the Internet connection to be lost.

    • BigDargon
    • 1 yr ago
    • Reported - view

    If you're using an iOS profile, follow these steps:
    - Access https://apple.nextdns.io/
    - Click More options
    - In the Excluded Domains, enter the domain captive.apple.com
    - Then download the new profile

      • Paul_Riverside
      • 1 yr ago
      • Reported - view

      BigDargon I'm using an Android device, is there a similar method that will work? Pixel 3 

      • BigDargon
      • 1 yr ago
      • Reported - view

      Paul Riverside Private DNS does not support Domain Exclusions :(

      • GuitarMatch
      • 1 yr ago
      • Reported - view

      Paul Riverside Not at all what BigDargon suggested, but on Android I installed https://f-droid.org/en/packages/com.jpwolfso.privdnsqt/ ("Private DNS Quick Tile") and added it to the quick settings menu. Allows me to quickly turn it on and off when I need to

      • Eric.9
      • 5 mths ago
      • Reported - view

      Does this also need to be performed for macOS devices?

      • BigDargon
      • 5 mths ago
      • Reported - view

       The profile applies to both iOS/iPadOS/MacOS so I think you should do the same on Mac OS.

      • TheAliDev
      • 4 mths ago
      • Reported - view

      but it has a allow list 

    • Dhrions
    • 5 mths ago
    • Reported - view

    Is the problem solved ? I've the same problem with a Linux laptop and an Android smartphone.

      • Martheen
      • 5 mths ago
      • Reported - view

       On Android use the Private DNS tile to toggle it off temporarily, on Linux write a script to temporarily switch the DNS setting. 

      • Dhrions
      • 5 mths ago
      • Reported - view

      Thanks. It's what I do but I look for an automatic solution.

Content aside

  • 3 Likes
  • 4 mths agoLast active
  • 13Replies
  • 1058Views
  • 13 Following