Impaired In-App Fitbit Functionality

Had a family member who wasn't able to use some of the In-App functions of the Android Fitbit app on WiFi with NextDNS configured. Apparently some of the In-App functionality routes through "www.google-analytics.com" since Google owns Fitbit now but this domain is blocked by the NextDNS blocklist.

Just FYI for any who use the Android Fitbit App

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hey thanks for this post. I'm also on Android and experiencing this in app Fitbit issue. I tried your suggestion but it didn't fix the app, still get this screen. When I check my logs, nothing shows as being blocked. When I disable nextdns, the app works normally. So it's definitely happening by nextdns but not showing in the logs. 

      • Hey
      • Hey
      • 3 wk ago
      • 1
      • Reported - view

      Jon Knight I'd say try using OISD only first as it's the simplest way to see if things would work or not, otherwise it could require manually whitelisting the blocked domains to figure out what exactly caused this issue. The DNS itself can't exactly cause it so something has to be blocked.

      Like 1
    • Hey thanks for the suggestion. OSID only seemed to fix Fitbit. Further testing seemed to isolate the issue to Steven Black Blocklist. This is incredibly disappointing as that is my primary Blocklist based on analytics. Again with the logs, I couldn't find a blocked entry to add to the Allowlist so something is going on behind the scenes. 

Like1 Follow
  • 2 wk agoLast active
  • 3Replies
  • 126Views
  • 3 Following