0

EdgeOS LAN client names not always propagated

I installed netxdns-cli on my EdgeRouter ER-X -SFP using the default options:

Report device name? [Y|n]: y

Enable caching? (y/n): y

Enable instant refresh? (y/n): y

Device names are reported through to the NextDNS logs, but not in all cases. Some devices, for example Chromebooks, don't report any name at all in the NextDNS logs. Configuring a hostname for the device in the EdgeRouter's DHCP static map does not seem to help.

Is there any way to either configure an alias (based on the IP address) in NextDNS, or to force the nextdns-cli client on EdgeOS to pay attention to hostnames configured in the router's DHCP static map?

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • A workaround (non-ideal?) is to disable caching in nextdns, so that dnsmasq on the EdgeRouter is enabled, and your static-host-mappings are honoured:

    1. Remove nextdns
      1. sh -c 'sh -c "$(curl -sL https://nextdns.io/install)"'

         

      2. Select option to remove nextdns
    2. Remove (or relocate) the old nextdns.conf from 
      /config/nextdns/nextdns.conf

      Otherwise, the net time you install, the installer sees the non-zero cache size in the old config file, and it disables dnsmasq once again

    3. Reinstall nextdns. This time, say "n" to the "Enable caching?" option
    Like
  • An alternative might be to leave nextdns caching enabled, and use the discovery-dns option to point to dnsmasq (running on another port, not :53), e.g. as discussed in https://github.com/nextdns/nextdns/issues/365. I haven't tried that yet.

    Like
Like Follow
  • 1 mth agoLast active
  • 2Replies
  • 38Views
  • 2 Following