0

Unable to resolve google.com in Safari Private Browsing mode

Hello,

I was having difficulty accessing google.com in Safari with Private Browsing mode enabled for the past few days. As the included video had demonstrated the browser are stuck loading google.com for seemingly endless time, and caused some wired glitch when search using address bar. I was able to reproduced this behavior on multiple iOS/iPadOS 14.6 devices. Disable my custom configuration also doesn’t resolved the issue.

The only way to fix I have found is to either use other third party browser, don’t enabled Private Browsing for Safari, or disable NextDNS.

On MacOS 11.4 google.com can be loaded, but would take significantly longer loading time of 10 to 15 seconds compare to split second of other browser including Safari without Private Browsing modes enabled.

Here is my diagnostics log from my Mac: https://nextdns.io/diag/163e7000-c858-11eb-84fe-8f28e270adaf

Hope this issue can be resolved soon since I mainly browsed the web with Private Browsing enabled. Thank you for your time.

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Looks like you've pre-copied the truncated non-HTTPS google url prior to pasting it and it seems it's not auto-redirecting to the secure site.

    If you're copying/pasting in private mode, you'll likely need to make sure it's the full HTTPS url (https://www.google.com) instead of the truncated HTTP url (http://google.com) or just use the address/omni bar to search without manually entering the url

    Like 1
      • Mike H.
      • Mike_H
      • 3 days ago
      • Reported - view

      First, I would like to mentioned this issue seems to have resolved a day or two after I posted this bug report. I have no longer experienced this issue.
       

      Greg B. Thank you for your reply. Regarding the truncated URL. It is actually just an oversight of me trying to make a bug demo video while avoid showing personal information including address bar auto-suggestions for the sixth times. I can be very sure that’s not the main reason why google.com failed to resolve since the bug can be triggered with my bookmark (which I disabled in this video) that has URL https://www.google.com/?hl=en-US stored. Or just typed Google.com in the address bar would have similar effect as a short clip from one of my failed demo video have shown that I have included with this reply. It also doesn’t explained why Google photo search is broken when NextDNS was enabled in the later part of the original demo video.

      Like
Like Follow
  • 2 days agoLast active
  • 2Replies
  • 39Views
  • 3 Following