1

DoH max concurrent queries reached, ignoring query - DoH server connection error: Idle timeout - waiting data, DoH server connection error:

I have been experiencing several errors on MikroTik router RB5009 as shown in the attached photos. I have included my router DNS configuration if anyone is able to assist? 

36 replies

null
    • R_P_M
    • 1 yr ago
    • Reported - view

    Did you try increasing the “maximum concurrent queries” value? Any difference or is the current number the maximum allowed by the router?

      • Chris.20
      • 1 yr ago
      • Reported - view

      R P M hi mate, I have tried as suggested and the error disappear for a short while and re-appear again. 

    • Chris.20
    • 11 mths ago
    • Reported - view

    Just noticed latest MikroTik version 7.8 introduce some DoH fix. Still not sure if the issue is MikroTik and NextDNS?

      • Robdejonge
      • 10 mths ago
      • Reported - view

      Chris Did you ever figure this out?

      • Chris.20
      • 10 mths ago
      • Reported - view

      Rob de Jonge Hi mate, nah. Still experiencing same issue and now when I am experiencing the timeout, webpages doesn't work. Thinking of switching to another provider :(

      • Robdejonge
      • 10 mths ago
      • Reported - view

      Chris You and me both. Just not sure where to! :)

      • Patrick_De_Zordo
      • 9 mths ago
      • Reported - view

      Chris Same problem here.. Is it a known bug? working with other DoH-Providers (working without problems!) :-(

      • Patrick_De_Zordo
      • 9 mths ago
      • Reported - view

      Chris ..and as a note: it was running for 2 weeks - untill I switch to the paid version today..

      • Patrick_De_Zordo
      • 9 mths ago
      • Reported - view

      Chris What IP adresses are you using for "dns.nextdns.io"?

      • Chris.20
      • 9 mths ago
      • Reported - view

      Patrick De Zordo Hi Patrick, find the attached IP's below...

      • Chris.20
      • 9 mths ago
      • Reported - view

      Patrick De Zordo The same with me, all started when I switched to paid version.....

      • Patrick_De_Zordo
      • 9 mths ago
      • Reported - view

      Chris from which country are you using nextdns?

      • Chris.20
      • 9 mths ago
      • Reported - view

      Patrick De Zordo Australia

      • Patrick_De_Zordo
      • 9 mths ago
      • Reported - view

      Chris could you try the following IPs?

      207.148.84.39, 103.1.213.21 for dns.nextdns.io

      • Chris.20
      • 9 mths ago
      • Reported - view

      Patrick De Zordo Thanks Patrick, changed the IP as suggested. Will report back....

      • Chris.20
      • 9 mths ago
      • Reported - view

      Patrick De Zordo Still having issues as per the screenshot attached.  As highlighted in the screenshot, MikroTik version 7.9 introduced new features in the DNS settings...... any idea/suggestions of the optimal values??

      • Patrick_De_Zordo
      • 9 mths ago
      • Reported - view

      Chris we are using the following settings, and we get just 1-5 timouts a day..

      it's not perfect, but "ok" for now..

      • Chris.20
      • 9 mths ago
      • Reported - view

      Patrick De Zordo Made the changes and timeout increased....... not sure what more I can do

      • Anh_Vu
      • 9 mths ago
      • Reported - view

      Chris  same issued at Viet Nam, did nextdns change something?

      • Chris.20
      • 9 mths ago
      • Reported - view

      Anh Vu Hey mate, not sure what NEXTDNS did but it has been a nightmare since the error started filing up log file. To make it worse, this is a paid version and nothing official from NEXTDNS staff!!!

      • Anh_Vu
      • 9 mths ago
      • Reported - view

      Chris  

      Today, I found reason to make nextdns timeout by enable rule dns in logging. So some device in my home network was tried to connect from their server like bitcoin from china and hongkong. Then I create rule to drop connection from list in firewall then connection timeout reduced.

      I'm not good at English, so I hope you guys understand.

      • Patrick_De_Zordo
      • 8 mths ago
      • Reported - view

      Anh Vu yeah, we understand! 👍

      Since yesterday we are using "ultralow1" and "ultralow2" server IPs for "dns.nextdns.io".

      Here in Italy the 2 IPs we are using: 178.255.155.63 and 192.145.127.148 - for now we have had 12 hours without any "timeout" or "connection error". (ROS 7.9 on x86)

      Can you check your "utlralow" servers in your country by opening the following page please?

      https://ping.nextdns.io/

      • Chris.20
      • 8 mths ago
      • Reported - view

      Patrick De Zordo how did you obtain IP addresses for "ultralow1/2"? I have attached screenshot from ping.nextdns.io

      • Chris.20
      • 8 mths ago
      • Reported - view

      Anh Vu Nice work mate. Anh Vu I have enable DNS logging and I can only see private IP's and not public IP on my list which if blocked the router would break 

      • Patrick_De_Zordo
      • 8 mths ago
      • Reported - view

      Chris it (should) be documented somewhere; can't find it right now, but it's really simple:

      ultralow1=gsl-adl this will become ipv4-gsl-adl-1.edge.nextdns.io => 116.90.72.196

      ultralow2=zetta-adl this will become ipv4-zetta-adl-1.edge.nextdns.io => 119.252.93.133

      So just use the 2 IPs for 2 static DNS records for "dns.nextdns.io",  and configure DNS parameters as in my screenshots.

      Then try to observe if it is working better..? 😉

Content aside

  • 1 Likes
  • 8 mths agoLast active
  • 36Replies
  • 2122Views
  • 7 Following