3

Native DoH does not work anymore in Windows 11

Since recent changes in NextDNS after setup DoH native in Windows 11 my.nextdns.io report that

"This device uses NextDNS without configuration.
Make sure you use the DNS servers shown in the Connected IP Addresses section below (DNS servers change depending on your configuration).".

But It should using exactly this config with valid id.

Workaround is just install and using YogaDNS - no more this prompt. 
 

11 replies

null
    • YL_G
    • 1 yr ago
    • Reported - view

    For your DNS Servers try using https://dns.nextdns.io/###### vs dns1.nextdns.io or dns2.nextdns.io

    • TuX
    • 1 yr ago
    • Reported - view

    Same for me. Does not work in Win11 any suggestions?

    • 3xploiton3
    • 1 yr ago
    • Reported - view

    i use DOH in windows 11 doesn't work too

    • Liberty_Grunt
    • 1 yr ago
    • Reported - view

    Completely ridiculous that support wouldn't push out a message to subscribers experiencing issues configuring NextDNS natively or via their Windows app.

    • Mark_Celino_R_Miranda
    • 1 yr ago
    • Reported - view

    win11 user here. DOH is not working in Win11.

    Even with the correct DOH profile address, the Adblock and parental restrictions will not work if I use  the number zero at the end of the DNS IP address.

    • Mauricio_Rodrigues
    • 1 yr ago
    • Reported - view

    Same problem here in win 11, DoH native to win 11 keeps failing and often only the connection in legacy binding IP, but still the dns leak, I tested other DNS services and that doesn't happen, I even added the addresses natively via powershell but without success, the error and dns leak persist. Solution was to use the native client for win, but I don't like this type of solution since the system has native support.

      • Mauricio_Rodrigues
      • 1 yr ago
      • Reported - view

      Maurício Rodrigues 

      485 / 5.000

      Resultados de tradução

      Resultado da tradução

      star_border

      I managed to solve it by pointing directly to the DNS IPs of my region, following the commands in the CMD, first I identify the IP with the command: where what is between " is the name of the chosen server ping /n 6 ipv4-"edgeuno-for"-1 .edge.nextdns.io, after using the command where the IP will be discovered with the previous command and the DoH address will be that of your nextdns panel netsh dns add encryption server=200.25.66.71 dohtemplate="https://dns.nextdns .io/eacbf3/abc" autoupgrade=yes udpfallback=no

       

      Attention, "abc" is the name of your device, also remember to delete the " and change the IP

    • Mauricio_Rodrigues
    • 1 yr ago
    • Reported - view

    I solved the problem definitively by reading this post, the problem was in chrome

     

    https://help.nextdns.io/t/60h0s4d/windows-11-doh-issue-this-device-is-using-nextdns-with-no-profile

    • fad3m1nd
    • 1 yr ago
    • Reported - view

    Confirmed. Disabling flag

    #enable-async-dns

     in Chrome WORKS. Thanks for tip. 

      • Mauricio_Rodrigues
      • 1 yr ago
      • Reported - view

      FadeMind 

      Is ultralow latencies working for you? natively?
      Here only with the windows app or yogadns or
      pointing directly to the IP of my region
      • fad3m1nd
      • 1 yr ago
      • Reported - view

      Maurício Rodrigues Ultralow is available only via yogadns or setup dns in browser (async dns should be in this scenario in default set, not disabled). Windows DoH still using Anycast. 

Content aside

  • 3 Likes
  • 1 yr agoLast active
  • 11Replies
  • 1200Views
  • 8 Following