Segmentation Fault

I'm getting a segmentation fault when trying to start/issue commands to NextDNS on Asus-Merlin.


It seemed fine until after a reboot. Now all I get is segmentation fault. Even after reboots.


Therion87@RT-AX86U-2978:/tmp/home/root# nextdns
Segmentation fault
4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I'm also using AX86U with Merlin and can confirm the "symlink/path" have never survived a reboot even though it should according to NextDNS team.  I have to enter the full path each time and have done so for 2 years now 😉

    Does it work if you enter the full path like this:
    /jffs/nextdns/nextdns <command>

  • I am also on an AX86U. It does not work with the full path.


    Therion87@RT-AX86U-2978:/tmp/home/root# /jffs/nextdns/nextdns
    Segmentation fault
    Therion87@RT-AX86U-2978:/tmp/home/root# cd /jffs/
    Therion87@RT-AX86U-2978:/jffs# ls
    addons          ca_files        nextdns         nvram           scripts         syslog.log-1    wglst.1
    asd             cert.tgz        nmp_cl_json.js  nvram_war       signature       usericon        zoneinfo
    asd.log         configs         nmp_vc_json.js  openvpn         syslog.log      wglst
    Therion87@RT-AX86U-2978:/jffs# cd nextdns/
    Therion87@RT-AX86U-2978:/jffs/nextdns# ls
    nextdns       nextdns.conf  nextdns.init
    Therion87@RT-AX86U-2978:/jffs/nextdns# nextdns
    Segmentation fault
  • Strange... Does any command work at all, like "nextdns config"?

    Did you use the default settings during install? Are you maybe low on RAM? Have you tried to uninstall and install it again?

  • So, no commands worked.

    Restarting didn't fix it. There wasn't a low memory issue.

    I manually deleted the installation path and reinstalled. Seems working for now. I will attempt to replicate it later.

    Like 1
Like Follow
  • 3 mths agoLast active
  • 4Replies
  • 21Views
  • 2 Following