0

nextdns status returns Error: unknown status:

Hello; I have NextDNS installed on Ubuntu and when ever i run nextdns status in the CLI it first returns back Error: unknown status: and then if i run that same status command a couple more times then it returns running.

Log:

May 11 02:08:23 NextDNS1 nextdns[3192]: Starting NextDNS 1.43.3/linux on :53
May 11 02:08:23 NextDNS1 nextdns[3192]: Listening on TCP/:53
May 11 02:08:23 NextDNS1 nextdns[3192]: Listening on UDP/:53
May 11 02:08:28 NextDNS1 nextdns[3192]: Setting up generic router
May 11 02:08:28 NextDNS1 nextdns[3192]: Activating
May 11 02:16:38 NextDNS1 nextdns[3192]: Connected 45.90.30.0:443 (con=3ms tls=14ms, TCP, TLS13)
May 11 02:16:38 NextDNS1 nextdns[3192]: Connected 188.172.221.9:443 (con=4ms tls=10ms, TCP, TLS13)
May 11 02:16:38 NextDNS1 nextdns[3192]: Switching endpoint: https://dns.nextdns.io#155.138.130.135,188.172.221.9,2001:19f0:b001:1bb:5400:2ff:fec8:6dcc,2605:380:55:450::7
May 11 02:21:33 NextDNS1 nextdns[3192]: Connected 188.172.221.9:443 (con=3ms tls=4ms, TCP, TLS13)

 

2 replies

null
    • R_P_M
    • 1 mth ago
    • Reported - view

    There was a bug previously where nextdns would flip between “not installed” and “running”. I’ve not looked at what was changed to fix that but maybe it could be linked?

    It’s more reliable to use this command on Ubuntu to see if NextDNS CLI is running or not:

    $ systemctl status nextdns 

      • cloudguru
      • 1 mth ago
      • Reported - view

       

      Thanks, I found the post of where the code was updated to what I am seeing. 
       

      Seems like the error I am receiving was added intentionally but I don’t know why I am even receiving that. Is it just a false positive message or is it actually stopping and running. 
       

      Seems to be something with systemd, you think I should move to a base OS like freeBSD where systemd won’t be an issue?

Content aside

  • 1 mth agoLast active
  • 2Replies
  • 55Views
  • 2 Following