0

Pfsense / NextDNS cli - client names

Hi all,

I've receintly setup the cli on pfsense. All is working as expected with the blocking and logging except some of the client names are showing in the logs with just a device number while others show the correct id.

All clients have static dhcp leases with their own client id's setup on pfsense . I did make some entries in the hosts file which cured the issue, but only temporarily as the hosts file enteries are lost whenever a config change is made on pfsense. I know another workaround would be to install the nextdns app on a device but thats not possible with some devices like IoT or cameras.

Anyone have any idea's ?

Many thanks.

10replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Do the hosts with no names in the logs have a name in the dhcp lease file?

    Like
  • not in the dhcpd.leases file but i've discovered the client names will show if the device is handed a dynamically assigned ip. (in which case it is in the lease file)

    If I create a static DHCP mapping as shown in the picture it won't show the name in the NextDNS logs 

    Like
    • David perhaps pfsense stores hostnames setup this way in separate location.

      Like
  • you've pointed me in the right direction, many thanks.

    Like
  • for now the workaround is to have the devices to obtain ip dynamically rather than have static mapping until I have the time to spend on finding the real cause.

    When / if I find a real fix then I'll post it here.

    Like
  • David,

    Just curious if you found a solution as I am having the exact same issue? Thank you.

    Like
  • no James unfortunately I didn't. I get round the issue by having the NextDNS app installed on mobile devices. For others you could edit the hosts file on the PfSense box for local name resolution  but then that is lost on a reboot.

    Like
  • This solution using the discovery-dns feature reported by a user on github resolved it for me:

    https://github.com/nextdns/nextdns/issues/341#issuecomment-706738980

    I used unbound (DNS Resolver) in pfsense instead of dnsmasq but it works the same way.

    In the pfsense resolver settings, make sure this is checked if you want static IPs (enabled):

    "Register DHCP static mappings in the DNS Resolver"

    The only thing that is still quirky sometimes is when a device favors an IPv6 address. I'll still usually get a random client name logged in nextdns then.

    Like
  • Hi Ksimm1!

    Thank you for sharing this.  Just a point of clarification:

    1.  NextDNS cli and DNS resolver shall be simultaneously enabled?

    2.  Custom field is blank?

    Is it possible for you to share a screenshot of your dns resolver page?

    Thanks a lot

    Like
Like Follow
  • 6 hrs agoLast active
  • 10Replies
  • 146Views
  • 5 Following