0

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

I cannot access my own site https://mission-control.app/ because of the following error on any browser.

 

This site can’t provide a secure connection
mission-control.app uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH
Hide details
Unsupported protocol
The client and server don't support a common SSL protocol version or cipher suite.

 

When I disable nextdns, it works. I also tried to add it in allowlist, but no luck. 

How do I fix this error?

 

 

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • It's blocked by NRD (the domains is less than 30 days old) and you probably enabled block page without adding the CA, hence the security error. Disable block page feature or add the CA if you want to get rid of those security errors.

    Like 2
      • Surjith
      • Surjith
      • 1 yr ago
      • Reported - view

      Olivier Poitrey Hi, I disabled the NRD already. but still, it didn't work. I tried restarting the OS, even disabled and enabled the Windows App again. No luck.

      What is CA? How do I add it?  

       

      Like
      • Surjith
      • Surjith
      • 1 yr ago
      • Reported - view

      Okay, I followed the steps here: https://help.nextdns.io/t/g9hmv0a/how-to-install-and-trust-nextdns-root-ca

      but error stays when NextDNS is active.  Is this a bug?

      Like
      • Greg B.
      • nisten
      • 1 yr ago
      • Reported - view

      Surjith Are you getting this error on Windows? If so, what version?

      Like
      • Surjith
      • Surjith
      • 1 yr ago
      • Reported - view

      Greg B. Yes, Windows 10. 

      Like
      • Greg B.
      • nisten
      • 1 yr ago
      • Reported - view

      Surjith I saw a prior post that was somewhat related but the cause was TLS version incompatibility. Is your site/system using at least TLS 1.2 ? Also what browser are you using on Windows?

      Fyi, I can access the https version of your site on Android (with the block page disabled)

      Like
      • Surjith
      • Surjith
      • 1 yr ago
      • 1
      • Reported - view

      Greg B. Thanks greg. I'm now able to access it.  I'm not sure what's the real reason. 

      I have cleared the SSL cache in Internet properties. Now I can access it. 

      Like 1
Like Follow
  • 1 yr agoLast active
  • 7Replies
  • 85Views
  • 3 Following