0

How to configure my Asus router for DoT DNS with NextDNS?

I need to find a couple of currently valid IP addresses and DNS server names for using DoT with NextDNS in my Asus router.

Currently using these IP's and server names in the WAN DoT DNS configuration on my router:

45.90.28.104 2c2b7b.dns.nextdns.io

45.90.30.104. 2c2b7b.dns.nextdns.io

which gives me this message on the "Setup" page:

This device is using NextDNS with another profile.

Make sure you are using one of the endpoints listed on this page.

Don't know what this message means, other than my DoT DNS server config above is wrong. And I don't see endpoint IP's or server names for DoT on "this page" :-).

Does anyone know what I should be using instead of what I have above for the DoT NextDNS configuration?

Thanks!

3 replies

null
    • MrDoh
    • 7 mths ago
    • Reported - view

    I did run test.nextdns.io, this is the output:

    {
    "status": "ok",
    "protocol": "DOT",
    "profile": "fp4737ee8ddffed2ab",
    "client": "76.209.240.36",
    "srcIP": "76.209.240.36",
    "destIP": "45.90.28.104",
    "anycast": true,
    "server": "zepto-bru-1",
    "clientName": "unknown-dot"
    }

    This does show that I'm getting DoT, that's good. But still the same message as above, with "...NextDNS with another profile".

    By the way, DNS leaktest shows 2 DNS providers, one of which is hostname dns.nextdns.io via the ISP "Anexia". The second one is in Belgium, via Cogent, with no hostname. So dns.nextdns.io is in the mix somewhere...anyways, thought I'd add that in case it was helpful to anyone :-).

     

       
     
         
     
         
     
         
      • MrDoh
      • 7 mths ago
      • Reported - view

      Okay, got an "All good" message now. Switched to this configuration:

      45.90.28.192 6664d4.dns.nextdns.io

      45.90.30.192 6664d4.dns.nextdns.io

      by taking the "use endpoints on this page" literally. Interestingly enough, the test.nextdns.io and DNS leaktest results are very similar to those using the original configuration.

      The original configuration above did work last time around, so things have been switched around on the NextDNS end since then as far as I can tell.

    • Dan_Taube
    • 3 wk ago
    • Reported - view

    The setup page for NextDNS details the following for DNS over TLS (note: it actually shows your own profile in the text, I just added 123456 for demonstration).

    ——-

    DNS-over-TLS/QUIC

    Prepend the name to the provided domain (the name should only contain a-z, A-Z, 0-9 and -). Use -- for spaces.

    For "John Router", you would use John--Router-123456.dns.nextdns.io as your DNS-over-TLS endpoint.

    ——-

    Based on what you described compared to the docs, you were indeed using a different profile.  If you want to identify your router in the logs you’ll still need to add a prefixed name to your DoT setting.

    I did this successfully on a ASUS ExpertWiFI EBR63.

Content aside

  • 3 wk agoLast active
  • 3Replies
  • 581Views
  • 2 Following