2

Windows 11 DoH issue - "This device is using NextDNS with no profile"

I've been using the app for a year now and was hoping to switch to a more native setup by using Windows 11's DNS over HTTPS. I uninstall the app, configure networking according to the instructions, and I get a "This device is using NextDNS with no profile" error message on the website. DNS resolution is working but there's no filtering whatsoever. Some of the requests show up on the logs but most don't.

Any ideas?

15 replies

null
    • NextDNs
    • 1 yr ago
    • Official response
    • Reported - view

    This is probably related to this bug in Chromium-based browsers:
    https://bugs.chromium.org/p/chromium/issues/detail?id=1409305

    Could you try the following and report back?

    1. In Chrome or any other chromium-based browser, go to the flags page (chrome://flags).
    2. Disable "Async DNS resolver".
    3. Restart the browser.

    It should now work. If it doesn't, could you post here what https://test.nextdns.io says in that browser?

      • xd003
      • 1 yr ago
      • Reported - view

      NextDNS Thanks that seem to have fixed the issue 

      • uncharted
      • 1 yr ago
      • Reported - view

      NextDNS This resolved this issue for me as well.

      • Scott_Mortimer
      • 1 yr ago
      • Reported - view

      NextDNS Excellent, fixed the problem for my Win11 machines. Suggest putting this info on the dashboard where users can see it with the other config for DOH.

      • Carlos_Avila
      • 1 yr ago
      • Reported - view

      NextDNS Thanks for the suggestion. You are right that this is a browser bug, I just tried it in Firefox and works fine.  I'm using Edge (112.0.1722.48 (Official build) (64-bit)) which despite being chromium-based doesn't seem to have that specific flag available. I also couldn't find an equivalent or similar flag. 

      This is what I get from test.nextdns.io:

      {
      "status": "ok",
      "protocol": "UDP",
      "client": "50.47.81.118",
      "srcIP": "50.47.81.118",
      "destIP": "45.90.28.0",
      "anycast": true,
      "server": "vultr-sea-1",
      "clientName": "unknown"
      }
      
      Any other suggestions would be appreciated, thanks.
      
      • kannanni
      • 1 mth ago
      • Reported - view

       I am not able to find this setting or option currently on edge or brave for windows 11. Can you please advice any other alternative solution?

    • xd003
    • 1 yr ago
    • Reported - view

    Facing the very same issue here

    • xd003
    • 1 yr ago
    • Reported - view

    @nextdns  can you please help fix this issue 

    • Luis_Radicheski
    • 1 yr ago
    • Reported - view

    i'm going through that same problem. apparently native support doesn't work

    • Mauricio_Rodrigues
    • 1 yr ago
    • Reported - view

    Thank you very much, I was experiencing the same problem and the solution was effective here.

    • Luis_Radicheski
    • 1 yr ago
    • Reported - view

    Here in chrome, it worked to disable sync, in Microsoft Edge is there already a solution?

    • Carlos_Avila
    • 1 yr ago
    • Reported - view

    For those using Edge you can use "Choose a service provider" in the browser settings and enter https://dns.nextdns.io/{Your_Profile_ID} to make it work. Hopefully this helps until we get a definitive solution.

    • Taodoggy
    • 7 mths ago
    • Reported - view

    I'm having this problem on my Windows 11 Pro machine running Chrome and Chrome Canary. After disabling Async DNS resolver, here are the results of https://test.nextdns.io:

    {
    "status": "ok",
    "protocol": "DOH",
    "client": "2604:2d80:4f80:a500:9d5b:8a60:f4b:66c4",
    "srcIP": "2604:2d80:4f80:a500:9d5b:8a60:f4b:66c4",
    "anycast": false,
    "server": "smarthost-mci-1",
    "clientName": "chromium-default"
    }
    • DRAFTER
    • 2 mths ago
    • Reported - view

    For anyone who use Microsoft EDGE Browser, a fix that I found is disabling "Built In Dns Client" on Edge.

    Download this reg file from elevenforum.com to disable it via Registry.
    https://www.elevenforum.com/attachments/always_turn_off_secure_dns_in_microsoft_edge_for_all_users-reg.52090/?hash=bc2050abb34a9d330b2b76fa62c88da9

    After that, close and reopen your Edge browser and test if it's working.
    https://test.nextdns.io/

      • kannanni
      • 1 mth ago
      • Reported - view

       this worked for edge, thank you.

      Is there a way I can achieve same results for brave browser? 

Content aside

  • 2 Likes
  • 1 mth agoLast active
  • 15Replies
  • 3266Views
  • 10 Following