0

Port 53 hijacked, also not sure my DOH is secure

I also have a 2nd video that demonstrates how my port 53 is being hijacked. In that video, the NextDNS app didn't work at all. See the 2nd video at https://youtu.be/z_hY7NEDkeg

5 replies

null
    • olivier
    • 2 yrs ago
    • Reported - view

    In the app, you need to configuration ID, link IP is only working when using unencrypted DNS on port 53. The reason only reason it's working is because you have firefox set to using DoH with the right configuration ID. You may just set the app with the right configuration ID and disable DoH in Firefox to have a full coverage of your system.

    The blockpage is showing up for the aaaa domain because you are not using https but http for it. Other pages you showed are https, and you don't seem to have the NextDNS root CA certificate installed properly so it shows a security error instead of the block page. 

    Comcast is not known to hijacking port 53.

      • I'm online with fairness and integrity + values here to learn
      • Chenzorone11
      • 2 yrs ago
      • Reported - view

      Olivier Poitrey proper config startup video of this cert. If available would be great footage please. ANYBODY.!?..

    • Ed_Jamison
    • 2 yrs ago
    • Reported - view

    Thank you for your reply.   You explained the process very well.  I did some more experimenting after I posted the support ticket and I seem to easily get it working perfectly when I connect with my hotspot, but the Comcast connection doesn’t allow me to get a connection with your AppStore app, it only allows me to connect with the Firefox NextDNS DOH settings.  I also couldn’t get your windows app to connect on Comcast either, but could get YogaDNS to work with your service on windows 10.  Who knows, maybe Yoga really isn’t working but I have a false sense of security thinking it is working.  As I stated, on my Mac, I can’t get your service to connect outside of Firefox when I’m on Comcast whether it be port 53 or your AppStore App, but that holds true no matter the service I use, it happens with opendns also.  I even tried your configuration file download since I’m on Big Sur, but it won’t stay activated.  It says inactive and when I change it to active, it instantly changes back to inactive the moment I click apply.   You truly do have a phenomenal product, my situation is very targeted, so the fact that I get your service to work at all is a plus.   

    I also started to get this error from time to time ( see attached )... my id is not the one below, I wasn’t logged in at the time. 

      • olivier
      • 2 yrs ago
      • Reported - view

      Ed Jamison you have xfinity safe browsing enable which block dns.nextdns.io. You will have to disable it first.

      • Ed_Jamison
      • 2 yrs ago
      • Reported - view

       Olivier Poitrey I disabled that weeks ago. I just checked again and it says its disabled. (see image at google link below ). Also, check out the other image below where the App Store shows your app as not even being installed even though it is clearly in my applications folder in the same image. I clicked to download it again and it didn't give me an error but must have just replaced the app already installed because the appstore now shows your app as being installed and able to open directly from the appstore. I had this same thing happen in 2014 where I was downloading from the appstore while simultaneously watching a realtime bandwidth app that told me which IP addresses were connected to each app. Halfway through the download, I saw the appstore open a connection to port 80 on a level3 ip address for a few seconds before switching back to the 17.** Apple IP Address. I was like WTF... See the 3 images at the google drive link below. https://drive.google.com/drive/folders/1XkE6i96zr5JLg2xTBkXj_22cjo0hbRp2?usp=sharing

Content aside

  • 2 yrs agoLast active
  • 5Replies
  • 317Views
  • 6 Following