0

AppleTV 4K won't log anything

Hey there. I didn't see this in searches so apologize if I am doubling up.

I've added a custom profile to the appletv successfully, it is verified and uses the AppleTV configuration id in my NextDNS account. However, when I use the apple TV I can tell that the settings I have for this profile are not working, and further while I try to debug it I get no logs, or filtering data on that profile at all, which leads me to believe that NextDNS is not doing anything here for the TV. What I do find is that it seems to be using my general Whole House configuration because I can see some of the logs from this TV on that profile.

 

Something doesn't make sense here, any chance anyone might know why that is happening?

11replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Which version of TvOS are you running?

    Like
    • Henk van Achterberg 14.4

      Like
  • For what it's worth, I put my iPad on same ID and I get logging for it and it recognizes the iPad name. Nothing for the TV still. iPad is on iOS 14.4 as well.

    Like
  • Do you have VPN (apps) installed or configured? and can you see the details of the profile in TvOS?

    Like
    • Henk van Achterberg No VPN apps installed on the AppleTV or network, no. Yes I can see all the details of the profile, and it's also showing green "verified", and I looked at the ID and it's the right profile ID. In fact, I don't see any logging for the TV even on the primary configuration for the router, so while I can watch programs on the AppleTV, I have no idea where the network requests are going.

      Like
    • Robert Sfeir Hmmz, strange, I would remove the profile, reboot the AppleTV, check if you can see the DNS queries in your primary configuration logs. If that is the case, generate a new profile and install it again (make sure there is no trailing space or something else in your ID) and see if that works.

      Like
    • Henk van Achterberg I followed your steps, and recreated the profile copying the profile ID and pasting, and doing no advanced configs at all and used a device name with no spaces either (bedroom_apple_tv). It worked! Thanks for your patience mate.

      Like
    • Robert Sfeir Awesome! It is nice when things work and you can spend time on other things :)

      Like
    • Henk van Achterberg Right? all this and NextDNS never stepped in. I appreciate this community, but man you'd think we see some support from NextDNS themselves here. Thanks again.

      Like
    • Robert Sfeir If we still have two people that are doing this, with their personal lives, covid, etc. I am grateful what they have done so far. Yes, we might be entitled to support but there is a reason why it is not happening right now and I hope and believe it is a good reason as they have put a lot of time and love in the product. Let's do our best to work with the situation as it is and I hope we will hear soon from the developers.

      Like 1
    • Henk van Achterberg Good point. Agreed.

      Like
Like Follow
  • 7 mths agoLast active
  • 11Replies
  • 76Views
  • 2 Following