Safari Hide IP Address

I have 2 NextDNS servers running in my house.  All my devices use these 2 NextDNS servers for DNS.  Any outbound DNS requests to anything other than my DNS servers, is blocked.

In Safari, with the Hide IP address feature enabled (which it is by default), NextDNS shows a linked IP that is not my IP, but a cloudflare IP, and says I am using cloudflare for DNS, not my NextDNS config.   If I disable that feature, it goes back to saying I am using my NextDNS Config, and has my correct IP.  

I'm running the Monterrey Beta, have been since Beta 1, and never noticed this until I really started using safari more as I was having an issue with Chrome.  Chrome correctly shows me using the NextDNS config for the network I am connected to, as well as my correct IP.

The reason I even noticed it, was I was having slow response times, in Safari but not Chrome, so I started looking into NextDNS and it showed up there.

Anybody else notice this?

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Cloudflare and Apple made ODOH , it's a DNS Proxy protocol that apple uses to mask what IP requests what Website. Basically your IP makes a request it goes to Apples servers and then from that server to Cloudflare so what Cloudflare sees is an Apple IP instead of your personal IP address. As Rob linked you to the page, NextDNS works, it just doesn't show your DNS as NextDNS and some people are saying Blockage makes NextDNS not work at all. It's all a bit weird, until Apple decides to fix it you have no option but to wait really. 

    Like 2
Like Follow
  • 2 wk agoLast active
  • 2Replies
  • 105Views
  • 3 Following