0

ERROR on YogaDNS

Hi, get this error when I try to make my DNS to NextDNS via YogaDNS.

I'm new to this DNS.  Please help.

DnsCrypt log: Get https://dns.nextdns.io/8b6d74?ct=&dns=yv4BAAABAAAAAAABAAACAAEAACkQAAAAgAAAAA: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Please try to uncheck the "ultra low latency" checkbox in the settings.

    Like 2
    • Olivier Poitrey Hi, I have the same problem on 1.16 beta. When trying to check "ultra low latency" it got me timeouts and after unchecking it's working fine using anycast. Is "ultra low latency still work in progress? (on my Firefox it uses low latency quite fine)

      Like
    • Marcin Drabek what do you get for https://ping.nextdns.io with nextdns disabled?

      Like
    • Olivier Poitrey What do you mean by "disabled"? I've attached screenshots from Edge when YogaDNS is on/off and also Firefox with configured NextDNS.

      Like
    • Marcin Drabek everything looks good. Do you have issues from another device on the same network with NextDNS?

      Like
    • Olivier Poitrey Yeah, it works. I have just been wondering why "ultra low latency" setting causes YogaDNS to not work with NextDNS - I managed to find some old thread suggesting adding server manually and disabling "ultra low latency" and then it worked but took me quite a bit of time to figure it out. Also I noticed the fact that NextDNS app (from instruction) causes problems with existing OpenVPN setup on my PC (so I moved to YogaDNS). What could cause the problem there?

      Like
    • Marcin Drabek it is not recommended to enter servers manually, it will work until it doesn't. Ultralow should just work for you. Some people have issues with ultralow when their Network is blocking the dns.nextdns.io domain, but this is not your case.

      A VPN can definitely conflict with NextDNS. YogaDNS is more robust in such configuration. I'm not sure what is going on in your setup.

      Like
    • Olivier Poitrey Ok, thanks for your replies. I suppose I'll leave it as it is now "until it doesn't (work)" then :) Most of the traffic comes from Firefox anyway so it should not be a big problem.

      Anyway, thanks and keep up the good work.

      Like
  • Just for others to know: here's how I managed to setup YogaDNS for NextDNS with "ultra-low latency" enabled:

    If you add the server manually (wizard didn't work for me) and want to enable "ultra-low latency" you need to remove the default IP YogaDNS provides for NextDNS and then check "ultra-low latency". After that suddenly the window changes (IP field disappers) and there are no "request rejected/unknown host" errors anymore when using "ultra-low latency" option.

    I think this is worth noting about YogaDNS as even the YogaDNS docs for NextDNS look a bit outdated (different view and no "ultra-low latency" option there).

    Like
Like Follow
  • 1 mth agoLast active
  • 9Replies
  • 147Views
  • 3 Following