0

NextDNS stops working after some time it has been configured...

Hello everyone...
I'm facing 2 problems that I don't know how to solve...

1 - NextDNS version 1.37.3-1 installed on my TP-Link WDR4300 router with OpenWrt version 21.02.0 r16279-5cc0535800 / LuCI openwrt-21.02 branch git-21.301.66596-f28aaa3...

I just went into software and looked for NextDNS and installed it, put my account ID and initially everything works great, including the locks I set up...

After a few hours working very well, DNS resolutions just stop working for all my devices on the network and it's no use restarting the NextDNS service and it's no use removing the service either, it only works again if I remove NextDNS from the router and restart the same.

Searching the internet, I found people with similar problems, who are reporting in this post below:

=> https://github.com/nextdns/nextdns/issues/246

We probably have more reports, however, I have limited time for searches...

I tried to do the proposed configuration from the command line, without configuring the cache, and I had the same problem - after a while, the resolutions just stop working.

2 - Mitrastar modem gpt-2541gnac-n1 model:
In this modem there is not much to be done in terms of software limitation... Equipment from an Internet operator here in Brazil, Vivo, similar to those used by Movistar at Epsanha and in other places where Telefonica operates...

Here I simply configure the modem pointing on your DNS servers (45.90.28.123, 45.90.30.123 and 2a07:a8c0::7f:2819, 2a07:a8c1::7f:2819).

And then I have the same problem... After some time configured, the equipment on the network behind the modem simply stops working in relation to DNS requests...

I did a test on a site that was having problems with DNS resolution and was without access, when testing access to the same site via IP address, it worked without major problems.

Is there anything I can be doing to resolve this? I bought an account from you just because I can't support so much advertising, ads and the like on my network anymore, but I'm having problems and I can't solve it at all.

In the case of Openwrt, the logs are not clear, I can't do an efficient troubleshooting about the problem pointed out.

Could you guys suggest something I might be doing to test it out, step by step?

Feel free to move the topic to the forum you think is correct.

I'm waiting. Thank you so far.

15replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • 29 views and no answer...

    Support, could you help?  I bought and paid the bill and I can't use it correctly?  The support and installation links didn't help my problems at all.

    Like
  • What do you get fron « nextdns log » when the problem happens?

    Like
    • NextDNS 

      I will try to get the logs when the problem occur.

      Right now, NextDNS is disabled where it works over Openwrt...

      And here where I could use the Mitrastar modem, I just make notes to the servers, so I believe I can't check the logs, except if they can be seen somewhere on the site (https://my.nextdns.io/) .

      Like
    • Rodrigo Roberti the cli logs are only available on the machine/router running it.

      Like 1
  • Ok, I understand it...

    Let's go by parts, we have 2 different scenarios...

    Let's try to check the possibilities on Openwrt, I think it's a little easier than on Mitrastar..

    Anyway, I'm going to reproduce the command line installation (ssh) in Openwrt here:

    Ok, I got it...

    Let's go by parts, we have 2 different scenarios...

    Let's try to check the possibilities on Openwrt, I think it's a little easier than on Mitrastar..

    Anyway, I'm going to reproduce the command line installation (ssh) in Openwrt here:

    Following the instructions at https://github.com/nextdns/nextdns/wiki...

    I chose not to use cache...

    I have install the luci-app-nextdns too.

    The log shows some problems, as can be seen in second and third images...

    The NextDNS information page shows me this information (last image):

    Now, I will wait for the eventual problem, and then, I will check the logs and share here with you...

    I share nextdns.conf with you too... 

    Like
  • Hello. Try configuring Stubby with Nextdns endpoint options

    Like
    • Matheus P hi Matheus... 

      How could I do this step by step please?

      In this moment, all works fine, I asked my wife to monitor the internet where she works, so I prefer to wait a little longer before we change the configuration, but thanks for the possibility.

      Like
  • I don't know if links are allowed here, if the link does not appear, search dns over tls openwrt on Google.

    [Tutorial] [No CLI] Configuring DNS over TLS with LuCI using Stubby and Dnsmasq - Installing and Using OpenWrt / Network and Wireless Configuration - OpenWrt Forum

    Like 1
  • More problems... 

    My wife call me and sad that your internet stops completely... 

    Making some tests, I´ve connect to router and open 2 sshs sessions, where in 1, I monitore the logs and in 2, I call ping commands from prompt of router... 

    What does it mean "context deadline exceed" ??? 

    The only way I can get the internet working properly is to uninstall NextDNS...

    Regarding NextDNS, I don't know what else to do... I can try the suggested Stubby configuration.

    Like
  • Given the problem pointed out last night in the last post, I decided that later today, to be honest, tonight (now it's 8:33 am / Brasilia time) to test the Stubby configuration proposed by @matheus_p, because I don't know what or where is the problem (I believe it's not on my equipment due to the "context deadline exceeds" message, but as I didn't get any more feedback, it was a bit difficult for me.
    Right now, NextDNS configuration is disabled in OpenWRT and we are using the provider's DNS locally.

    Like
      • Matheus P
      • Matheus_P
      • 3 wk ago
      • 1
      • Reported - view

      Rodrigo Roberti hello, I tested stubby yesterday, putting the configuration option proposed by nextdns (available on the router tab on the installation page), in the stubby.yml files and in /etc/config/stubby, removing the Cloudflare dns. The internet is running smoothly here, with no major crashes. Another thing I also did was disable the AI-Driven Threat Detection option, and I only use the adblock Energized host. See if any of these options are useful for you.

      Like 1
    • Matheus P starting now removing NextDNS cli and software from my router and configuring Stubby following your guide... Thanks.

      Like
  • What does it mean "context deadline exceed"  in log???

    Like
  • Hi all...

    Unfortunately I had numerous issues with Openwrt version 21.02.1 this week that caused me to downgrade to version 19.07.8.

    With that, I completely reconfigured the router on yesterday's date, around 23:00 hours (Brasilia time)...

    I've watched it work all day today, and it seems to work very well now...

    Let's wait for this next week, always monitoring to check if it's really OK...

    Thanks everyone for now!

    Like
Like Follow
  • 13 days agoLast active
  • 15Replies
  • 271Views
  • 4 Following