0

Captive Portal issue

Hi Team,

My wide AP ISP uses a captive portal where I can only use the internet after logging in with my creds successfully. Something like a public wifi would do but on a slightly larger scale. 

The captive portal gway IP is 172.16.0.1 and when I enter it on my browser, it redirects to portal: login.sync. Or I can do it the other way around and it will direct me to portal nonetheless.

After installing the NextDNS package on luci and configuring it, I am really happy that everything works well except, whenever I restart my router, I will need to disable the NextDNS service to allow me to login to captive portal because it just wouldnt open it. This is the error message that comes up.

DNS_PROBE_FINISHED_NXDOMAIN

I have gone through some discussions here and outside to find a way around it without success. 

Rebind protection has been toggled off with no effect.

Heres my nextdns config

config nextdns 'main'
    option setup_router '1'
    option report_client_info '1'
    option log_queries '0'
    option bogus_priv '0'
    option auto_activate '1'
    option max_ttl '0s'
    option cache_size '10MB'
    option detect_captive_portals '1'
    option use_hosts '1'
    option timeout '5s'
    list listen 'localhost:53'
    option cache_max_age '0s'
    option control '/var/run/nextdns.sock'
    option hardened_privacy '1'
    option config '??????'
    option log_query '0'
    option enabled '1'

 

Any help is really appreciated. Thank you.

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Assuming that's the full portal login domain, you either need to whitelist portal.login.sync or create a DNS rewrite for the IP address

    Like 1
      • AisE.
      • Aisan_Estrella
      • 2 wk ago
      • 1
      • Reported - view

      Greg B. you are awesome Greg B.! so that is what the rewrite is for. solved my problem once and for all and I cant thank you enough 馃槃

      Like 1
      • AisE.
      • Aisan_Estrella
      • 2 wk ago
      • Reported - view

      also, i forgot to add on my first post that i also added the domain to whitelist but it didnt fix it.

      the rewrite did. 

      you can mark this as solved. thanks team

      Like
Like Follow
  • 2 wk agoLast active
  • 3Replies
  • 39Views
  • 2 Following