I can't make dnsv6 to work on router


The router is from the isp and I only have access to a user account, so some limitations apply. The user can't see and change everything and the software is customized, I can't change the software, the updates are done by them and they have remote access to the router. But except my issue with dnsv6 all the other settings works.

The manual setting for DNS work for DNSv4 but on v6 I tried different things but when I check the ones from the isp still resolve.

Strangely, as you can see, it ask for the expanded full dns and a prefix. The prefix really confused me, I searched for answers and failed. I tried different numbers: 0, 1, 12, 16, 24, 32, 64, 128, state ful, stateless and all the other options without result. I'm not technical apt on networking but I searched and tried to figure it out by myself without luck.

If someone knows what the problem is and want to help me, please do so.

Is it a setting available in the image or is it something from software that is the problem?

For time being I disabled dnsv6 and I use v4 with ddns on router and doh on phone but the fact that I can't make it work annoy me.

Maybe I should mention that the internet connection it's PPPoE, as I think this isn't very common. We have fiber to the building and Lan cable in the router.


3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • A prefix of /128 would target one specific IPv6 address - and I'd guess this is the right option.

    Make sure you expanded the IPv6 address correctly; use an expander calculator if you need to: https://dnschecker.org/ipv6-expand.php

  • Some more obvious questions: make sure your IPv6 actually works (without DNS): Did your router get IPv6 allocation from your ISP and is it distributing it with route advertisements internally to your devices? Can you ping6 (or ping -6) something like 2607:f8b0:400a:805::200e (google.com)?

  • Hello,

    I saw that /128 is the last one but I think /64 is the one, is everywhere in status and also in TV settings.

    The expanded one is found also in "Setup Guide" for routers, it is the right one. I tried others too.

    To all the other questions the answer is yes, it works but I can't get rid of the isp DNS. If the settings for DHCPv6 are OK and the prefix /64 is the right one it means that the customized software is set to ignore the manual setting for DNSv6. At least this is what I am inclined to believe.

Like Follow
  • 1 yr agoLast active
  • 3Replies
  • 84Views
  • 2 Following